Subject: Fixes for pgAdmin feature tests

From: Shubham Agarwal <[email-masked]>
Date: Mon, 11 Nov 2019 10:14:55 +0530

Hi Team,

Attached is the patch containing fixes for the failed feature test cases.
This patch contains-
1. Newly created function for traversing the browser tree.
2. Some synchronization issue fixes.
3. Modified locators.
4. Test cases fix for the recent commits.

-- 
Thanks & Regards,
Shubham Agarwal
EnterpriseDB Corporation

The Postgres Database Company

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 11 Nov 2019 10:54:54 +0530

Thanks, patch applied with a minor change. Menu for 'Delete Drop' server
has been changed to 'Remove Server' which causes all the test cases failing
on my machine.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Shubham Agarwal <[email-masked]>
Date: Tue, 12 Nov 2019 18:27:22 +0530

Hi Team,
PFA patch containing some more fixes for random feature test failures.

Thanks and regards,
Shubham Agarwal

-- 
Thanks & Regards,
Shubham Agarwal
EnterpriseDB Corporation

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 13 Nov 2019 11:19:38 +0530

Thanks, patch applied.

On Tue, Nov 12, 2019 at 6:27 PM Shubham Agarwal <
[email-masked]> wrote:

> On Mon, Nov 11, 2019 at 10:55 AM Akshay Joshi <
> [email-masked]> wrote:
>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Shubham Agarwal <[email-masked]>
Date: Fri, 15 Nov 2019 17:59:12 +0530

Hi Team,

PFA feature test fixture patch containing the following fixes:
1. Process watcher loading logs fix
2. Auto commit/rollback issue in query_tool_tests
3. Fixed the scrolling issue while verifying values in a table.
4. Modified some functions in pgadmin_page.py

-- 
Thanks & Regards,
Shubham Agarwal
EnterpriseDB Corporation

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 15 Nov 2019 18:03:25 +0530

Thanks, patch applied

On Fri, Nov 15, 2019 at 5:59 PM Shubham Agarwal <
[email-masked]> wrote:

> On Wed, Nov 13, 2019 at 11:19 AM Akshay Joshi <
>>>> Thanks, patch applied with a minor change. Menu for 'Delete Drop'
>>>> server has been changed to 'Remove Server' which causes all the test cases
>>>> failing on my machine.
>>>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Shubham Agarwal <[email-masked]>
Date: Wed, 20 Nov 2019 12:33:55 +0530

Hi Team,
PFA feature test fixture patch containing the following things:

1. Added an attribute 'data-click-counter' in query execute button which
gets incremented once query button is clicked up to 9 and then reset to 0.
This is added just to support automation.
2. Locator for login_group_role is added and used to expand tree.
3. Functions for enabling and disable auto_commit and auto_rollback are
made more precise.
4. Some scrolling problem is addressed in view_data_dml_query test.
5. Handled the stale element reference exception in query_tool_journey_test

Regards,
Shubham Agarwal

-- 
Thanks & Regards,
Shubham Agarwal
EnterpriseDB Corporation

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 20 Nov 2019 13:09:35 +0530

Thanks, patch applied.

On Wed, Nov 20, 2019 at 12:34 PM Shubham Agarwal <
[email-masked]> wrote:

> On Fri, Nov 15, 2019 at 6:03 PM Akshay Joshi <

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Shubham Agarwal <[email-masked]>
Date: Thu, 21 Nov 2019 15:39:42 +0530

Hi Team,
Attach is the patch for feature test fix containing the following:
1. Handled click event in query tool due to intermediate clicking issue.
2. Observed that the database is not getting created in a test case, so
failed the test case there only.

-- 
Thanks & Regards,
Shubham Agarwal
EnterpriseDB Corporation

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 21 Nov 2019 17:22:09 +0530

Thanks, patch applied.

On Thu, Nov 21, 2019 at 3:40 PM Shubham Agarwal <
[email-masked]> wrote:

> On Wed, Nov 20, 2019 at 1:09 PM Akshay Joshi <

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Shubham Agarwal <[email-masked]>
Date: Tue, 3 Dec 2019 18:09:34 +0530

Hi Team,

PFA patch for feature tests containing following fixes-

1. Modified the get_chromedriver utility for supporting python version
below 3.5.
2. Handled some exceptions getting intermittently on some databases.
3. Generalized some functions with additional parameters.
4. Disabled the auto-expansion of the children nodes for maintaining the
synchronization.

On Thu, Nov 21, 2019 at 5:22 PM Akshay Joshi <[email-masked]>
wrote:

>>>> 1. Added an attribute 'data-click-counter' in query execute button
>>>> which gets incremented once query button is clicked up to 9 and then reset
>>>> to 0. This is added just to support automation.

-- 
Thanks & Regards,
Shubham Agarwal
EnterpriseDB Corporation

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 3 Dec 2019 19:38:25 +0530

Thanks, patch applied.

On Tue, Dec 3, 2019 at 6:09 PM Shubham Agarwal <
[email-masked]> wrote:

> On Thu, Nov 21, 2019 at 5:22 PM Akshay Joshi <
>>>>> 3. Functions for enabling and disable auto_commit and auto_rollback
>>>>> are made more precise.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*