Subject: [pgAdmin][RM4696] Add RE-SQL/MSQL test cases for Materialized View

From: Rahul Shirsat <[email-masked]>
Date: Tue, 19 Nov 2019 12:47:16 +0530

Hi Hackers,

I have attached the patch for RE-SQL/MSQL test cases for View as well as
Materialized View.

-- 
*Rahul Shirsat*
Software Engineer | EnterpriseDB Corporation.

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 19 Nov 2019 18:27:35 +0530

Hi Rahul

Test cases failing on all EPAS servers. Please fix and send the patch again.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 21 Nov 2019 13:08:44 +0530

Hi Rahul

Some more review comments:

   - Don't create new file test_view.json as I tested and committed the old
   code.
   - Remove hardcoded "oid: 17869" from JSON file.
   - MSQL endpoints and file name missing in some test cases.
   - Cover all the controls in create and alter as much as possible.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Rahul Shirsat <[email-masked]>
Date: Sat, 23 Nov 2019 00:37:15 +0530

Akshay,

Please find the correction done in this updated patch based on your review
comments.

Regards,
Rahul Shirsat.

On Thu, Nov 21, 2019 at 1:08 PM Akshay Joshi <[email-masked]>
wrote:

>    - Don't create new file test_view.json as I tested and committed the
>    old code.
> On Tue, Nov 19, 2019 at 6:27 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Rahul
>>

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 25 Nov 2019 11:11:40 +0530

Thanks, patch applied.

On Sat, Nov 23, 2019 at 12:37 AM Rahul Shirsat <
[email-masked]> wrote:

> On Thu, Nov 21, 2019 at 1:08 PM Akshay Joshi <
>>>> I have attached the patch for RE-SQL/MSQL test cases for View as well
>>>> as Materialized View.
>>>>
>>>> --
>>>> *Rahul Shirsat*

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*