Subject: [pgAdmin4][Patch]: RM#1432 - File Browser - File does not exist error

From: Surinder Kumar <[email-masked]>
Date: Wed, 6 Jul 2016 15:12:16 +0530

Hi

Please find the patch with issue fixed:
File Browser - File does not exist error

> it is due to wrong path formation. strip the leftmost slash only from the
> file name selected not from the full path.

Please review.

*Reply to the comments:*
The file browser is virtually unreadable (see screen shot), it does not
work like Mac app
It seems to be font issue to me. I will fix it and send a patch.

When I click on the folder name, it offers to change the folder name
instead of opening it (opening works when I click on the folder logo)
we are performing two operations on double click:
1) Navigate inside the folder
double clicking on folder icon allows to navigate inside the folder.
2) Rename folder
double clicking on folder name allows to rename the file/folder.

When I manage to navigate to the right file and want to open it, I get a
red message ‘File does not exist’. That message disappears after 2-3 seconds
attached a patch with fix.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Wed, 6 Jul 2016 13:10:35 +0100

Hi,

I think we need more changes than just that;

- The path at the top should not be editable (it should be greyed in fact)

- The path at the top should only show the directory path. The
filename should never be appended.

- The CSS needs to be fixed so the filename textbox at the bottom is
never hidden (as it is now if the dialogue opens at a small size).

- Double-click to navigate vs. rename should be modified to work in
part like it does on Mac - Double-click on either the icon or the name
should open the item (browser into a folder, or select and "OK" on a
file), and Click then Enter should rename. I'm hesitant to try to
implement "slow double click to rename" as that would likely need to
be tunable for accessibility reasons.

On Wed, Jul 6, 2016 at 10:42 AM, Surinder Kumar
<[email-masked]> wrote:
> Reply to the comments:
> The file browser is virtually unreadable (see screen shot), it does not work
> like Mac app
> When I click on the folder name, it offers to change the folder name instead
> of opening it (opening works when I click on the folder logo)
> When I manage to navigate to the right file and want to open it, I get a red
> message ‘File does not exist’. That message disappears after 2-3 seconds

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 6 Jul 2016 19:02:11 +0530

> - The path at the top should not be editable (it should be greyed in fact)
Ok

> filename should never be appended.
Ok

> never hidden (as it is now if the dialogue opens at a small size).
Ok

> be tunable for accessibility reasons.
Ok, I will fix it.

> work
> instead
> red

---

From: Surinder Kumar <[email-masked]>
Date: Thu, 7 Jul 2016 18:20:16 +0530

>> be tunable for accessibility reasons.
In the current scenario, the Enter Key is bound to the OK button by default
in Alertify dialog which servers the purpose of closing the dialog.
Should we de-attach Enter Key event bound to OK button and use it for
rename file?
please suggest what should I do?

---

From: Dave Page <[email-masked]>
Date: Mon, 11 Jul 2016 14:11:42 +0100

On Thu, Jul 7, 2016 at 1:50 PM, Surinder Kumar
<[email-masked]> wrote:
> On Wed, Jul 6, 2016 at 7:02 PM, Surinder Kumar
> Should we de-attach Enter Key event bound to OK button and use it for rename
> file?

Hmm, good point.

How hard would it be to look for 2 consecutive single-clicks (but not
a double-click) for rename? If we can do that, it avoids timing
considerations for double-clicks (which would be defined by the OS).

---

From: Surinder Kumar <[email-masked]>
Date: Tue, 12 Jul 2016 11:40:07 +0530

On Mon, Jul 11, 2016 at 6:41 PM, Dave Page <[email-masked]> wrote:

> rename

I tried to implement slow double click, here is Fiddle
<https://jsfiddle.net/5kwn6mj2/#>
There are two events 1) double click (it will be used for folder navigation)
2) Slow double click(For rename), It is a simple click event, when clicked
twice after delay we consider it a slow double click.

But it is not working smoothly, double click and single click events are
conflicting.

Also, we have rename button in navigation for rename operation,
Can we skip slow double click because it is very confusing?

---

From: Dave Page <[email-masked]>
Date: Wed, 13 Jul 2016 12:45:24 +0100

> But it is not working smoothly, double click and single click events are

Yeah, so I see.

> Can we skip slow double click because it is very confusing?

OK, I must have been having a brain failure moment or something. Yes,
skip it - we obviously don't need it with the rename button.

So we have:

- Click to select
- Double click to open a folder
- Button to rename the select file/folder

Sorry!

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 13 Jul 2016 19:20:11 +0530

Please find updated patch with following changes/enhancements:

   1. Double click on file/folder icon or name will navigate to the
   folder/file.
   2. Selected file/folder can be renamed by Rename button only. Double
   click rename is removed.
   3. Filename text box will not hide on smaller screen. Setting minimum
   width of File Browser fixed it.
   4. Path at top will only show directory name, not the file name and it
   is greyed out.

*Issue not fixed:*
Icons and fonts of Query tool and File Browser looks blurred in Runtime
environment.
I tried debugging it. while debugging, It gets fixed on my ubuntu runtime.
but I don't know how it gets fixed without changing css styles. It needs
more time to debug.

Please review.

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 13 Jul 2016 19:23:03 +0530

I forgot to merge the fix for issue "File Browser - File does not exist
error" in the patch.
Please ignore this patch.

On Wed, Jul 13, 2016 at 7:20 PM, Surinder Kumar <
[email-masked]> wrote:

>> >> >>> - The path at the top should not be editable (it should be greyed
>> in
>> >> >>> fact)
>> >> >>
>> >> >> Ok
>> >> >>>
>> >> >>>

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 13 Jul 2016 19:28:05 +0530

Please find updated patch.
This patch also includes the fix for issue  "File Browser - File does not
exist error".

On Wed, Jul 13, 2016 at 7:23 PM, Surinder Kumar <
[email-masked]> wrote:

>>    4. Path at top will only show directory name, not the file name and
>>    it is greyed out.
>>
>> *Issue not fixed:*
>> I tried debugging it. while debugging, It gets fixed on my ubuntu
>> runtime. but I don't know how it gets fixed without changing css styles. It
>> needs more time to debug.
>>
>> Please review.
>>

---

From: Dave Page <[email-masked]>
Date: Fri, 15 Jul 2016 10:52:03 +0100

Thanks Surinder, patch applied.

I suspect the font rendering issue is related to others we've seen,
where the solution is to ensure the -webkit-transform CSS attribute is
set to none. Can you have a poke around with it please?

On Wed, Jul 13, 2016 at 2:58 PM, Surinder Kumar
<[email-masked]> wrote:
> On Wed, Jul 13, 2016 at 7:23 PM, Surinder Kumar
>> On Wed, Jul 13, 2016 at 7:20 PM, Surinder Kumar
>>> Double click on file/folder icon or name will navigate to the
>>> folder/file.
>>> Selected file/folder can be renamed by Rename button only. Double click
>>> rename is removed.
>>> Filename text box will not hide on smaller screen. Setting minimum width
>>> of File Browser fixed it.
>>> Path at top will only show directory name, not the file name and it is
>>> greyed out.
>>>
>>> Issue not fixed:

---

From: Surinder Kumar <[email-masked]>
Date: Fri, 15 Jul 2016 15:26:48 +0530

> set to none. Can you have a poke around with it please?
Sure Dave. I will do.

> >>>> >> >>> - The CSS needs to be fixed so the filename textbox at the
> bottom
> >>>> >> >>> is
> >>>> >> >>> - Double-click to navigate vs. rename should be modified to
> work
> >>>> >> >>> in
> >>>> >> >>> part like it does on Mac - Double-click on either the icon or
> the
> >>>> >> >>> name
> >>>> >> >>> implement "slow double click to rename" as that would likely
> need
> >>>> >> >>> to
> >>>> >> > In the current scenario, the Enter Key is bound to the OK button
> by
> >>>> >> > default