Subject: [pgAdmin4][Patch]: RM1595 - "no results to fetch error" displayed if modify definition with other table

From: Surinder Kumar <[email-masked]>
Date: Fri, 16 Sep 2016 15:44:41 +0530

Hi

*Issues fixed:*

1) Creating a m-view with *definition* and then updating view with* new
definition,* it results into an error *"No results to fetch"*.

2) When definition of m-view is updated, it creates a new m-view with
different OID, but it wasn't updating the old OID with new OID of tree node
in tree view. thus on switching to another tab (e.g.: sql), it throws
message *"Cannot find materialized view"*.

Please find attached patch and review.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Fri, 16 Sep 2016 15:41:17 +0100

Thanks, applied.

On Fri, Sep 16, 2016 at 11:14 AM, Surinder Kumar
<[email-masked]> wrote:
> Hi
>
> Issues fixed:
>
> 1) Creating a m-view with definition and then updating view with new
> definition, it results into an error "No results to fetch".
>
> message "Cannot find materialized view".
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company