Subject: [pgAdmin4][Patch]: RM1682 - create new Procedure option should not available on System catalog

From: Surinder Kumar <[email-masked]>
Date: Mon, 12 Sep 2016 10:42:13 +0530

Hi

*Please find attached with following fixes:*

1) The function '*canCreateProc*' that checks if package is auth to create
under catalog gets failed due to improper check of 'type'. Instead check
should be like
node_hierarchy['server'].*server_type* == "ppas" not
node_hierarchy['server'].*type* == "ppas"

2) Also found, *package.js* was loading at schema level, due to this,
context menu doesn't popup under catalog. Now it is load at database level.

3) In *package.js*, remove extra comma from columns array.

4) Rule create option should not available on table under catalogs. Fixed.

Please review.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 12 Sep 2016 11:13:30 +0530

Hi Surinder,

Just a heads up, When server is not connected and listed down in browser
tree then node has attribute 'type' instead of 'server_type'.
I have fixed similar issue few days ago Ref. link
<https://git.postgresql.org/gitweb/?p=pgadmin4.git;a=commit;h=013ff1090e4b084166077a9e43196a91d7e17e24>

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

On Mon, Sep 12, 2016 at 10:42 AM, Surinder Kumar <
[email-masked]> wrote:

> 1) The function '*canCreateProc*' that checks if package is auth to
> create under catalog gets failed due to improper check of 'type'. Instead
> check should be like

---

From: Surinder Kumar <[email-masked]>
Date: Mon, 12 Sep 2016 11:51:06 +0530

On Mon, Sep 12, 2016 at 11:13 AM, Murtuza Zabuawala <murtuza.zabuawala@

> <https://git.postgresql.org/gitweb/?p=pgadmin4.git;a=commit;h=013ff1090e4b084166077a9e43196a91d7e17e24>
 Yup this was a
​bug
.
​ Previously, *server_type* was not returned​ on listing down after
disconnect then connect.
 And
​
it has already been taken care in this commit​
<https://www.postgresql.org/message-id/[email-masked]>
.
 So, the check will work fine with *server_type​. *

---

From: Dave Page <[email-masked]>
Date: Mon, 12 Sep 2016 11:37:48 +0100

Thanks, applied.

On Mon, Sep 12, 2016 at 6:12 AM, Surinder Kumar
<[email-masked]> wrote:
> Hi
>
> Please find attached with following fixes:
>
> 1) The function 'canCreateProc' that checks if package is auth to create
> node_hierarchy['server'].server_type == "ppas" not
> node_hierarchy['server'].type == "ppas"
>
> 2) Also found, package.js was loading at schema level, due to this, context
> menu doesn't popup under catalog. Now it is load at database level.
>
> 3) In package.js, remove extra comma from columns array.
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company