Subject: [pgAdmin4][Patch]: RM1579 - Unable to scroll the query text window during selection

From: Surinder Kumar <[email-masked]>
Date: Thu, 15 Sep 2016 13:24:36 +0530

Hi

*Please find the attached patch patch with following changes:*

1) Implemented CodeMirror addon 'simplescrollbars'.

2) The CodeMirror instance of query tool was not rendering into
wcDocker's *'pg-panel-content'
div*. it renders outside the div, due to which it took little more time
investigating why scrollbars doesn't appear in editor.

3) Add new css specific to query tool.

Please review.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Thu, 15 Sep 2016 09:08:19 +0100

(pgadmin4)piranha:pgadmin4 dpage$ git apply ~/Downloads/RM1579.patch
error: patch failed: web/pgadmin/static/css/overrides.css:53
error: web/pgadmin/static/css/overrides.css: patch does not apply

Please rebase!

On Thu, Sep 15, 2016 at 8:54 AM, Surinder Kumar
<[email-masked]> wrote:
> Hi
>
> Please find the attached patch patch with following changes:
>
> 2) The CodeMirror instance of query tool was not rendering into wcDocker's
> 'pg-panel-content' div. it renders outside the div, due to which it took
> little more time investigating why scrollbars doesn't appear in editor.
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Surinder Kumar <[email-masked]>
Date: Thu, 15 Sep 2016 14:34:07 +0530

Hi

Please find updated patch.

On Thu, Sep 15, 2016 at 1:38 PM, Dave Page <[email-masked]> wrote:

> wcDocker's

---

From: Dave Page <[email-masked]>
Date: Thu, 15 Sep 2016 10:17:04 +0100

Thanks, applied.

One minor tweak to look at - in firefox, the width of the left margin
in the query tool changes when you add a line, if the font size in
preferences is not set to 1em. I think the width is initially sized
for the font, then gets adjusted as you hit return. This doesn't seem
to affect Chrome, and is only a minor annoyance in Firefox.

---

From: Surinder Kumar <[email-masked]>
Date: Thu, 15 Sep 2016 14:54:21 +0530

> to affect Chrome, and is only a minor annoyance in Firefox.
​Ok, I will look into it.​