Subject: [pgAdmin4][Patch]: Listing of files/folders not sorted alphabetically in Storage Manager

From: Surinder Kumar <[email-masked]>
Date: Fri, 7 Oct 2016 13:18:41 +0530

Hi,

*Issues fixed:*
1) Listing of files/folders not sorted alphabetically.
2) Some file names are truncated despite the fact that there is plenty of
room to be displayed.

*Not Fixed:*
In Table mode, clicking on Name bar makes no difference.
As discussed with Ashesh we are not implementing it now. It requires a lot
of changes with current implementation.

Please find attached patch and review.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Fri, 7 Oct 2016 12:40:17 +0100

Hi

The patch fixes the filename length issue, but does not seem to
resolve the sorting. Please see the attached screenshot.

On Fri, Oct 7, 2016 at 8:48 AM, Surinder Kumar
<[email-masked]> wrote:
> Issues fixed:
> Not Fixed:

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Surinder Kumar <[email-masked]>
Date: Mon, 17 Oct 2016 13:02:05 +0530

​Hi Dave,

As we have already been using natural sort in pgAdmin4 for sorting browser
tree nodes. So I have used the same for sorting Storage Manager's
filesystem.
Please find updated patch and let me know for comments.

---

From: Dave Page <[email-masked]>
Date: Tue, 18 Oct 2016 11:40:02 +0100

Thanks, applied.

On Mon, Oct 17, 2016 at 8:32 AM, Surinder Kumar
<[email-masked]> wrote:
> Hi Dave,