Subject: [pgAdmin4][Patch]: RM1674 - Reverse engineered SQL for functions with default values is incorrect

From: Surinder Kumar <[email-masked]>
Date: Tue, 13 Sep 2016 17:11:11 +0530

Hi

*Patch with following changes:*

1) In SQL pane, the signature in comments had arguments with name and type,
Now it will show arguments with type only.

2) There is no indent+newline between arguments (there isn't even a space).
- Fixed

3) The default value for the last argument is omitted. - Fixed
Last argument is omitted because the value for the last argument we got
from table is empty.
Now we form function signature in the *get_definition.sql *using *'*
*pg_catalog.pg_get_function_arguments*' method.

Above changes will reflect in Functions, Procedures & Trigger function
Nodes.

Please review attached patch.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Wed, 14 Sep 2016 11:00:45 +0100

Thanks - committed with a couple of minor formatting tweaks:

- Remove the leading space before arguments (e.g. s/, /\r\t/ instead
of s/,/\r\t/)
- Put the first argument on a new line as well.

Please double-check I didn't break anything that I've missed!

On Tue, Sep 13, 2016 at 12:41 PM, Surinder Kumar
<[email-masked]> wrote:
> Hi
>
> Patch with following changes:
>
> Last argument is omitted because the value for the last argument we got from
> table is empty.
> Now we form function signature in the get_definition.sql using
> 'pg_catalog.pg_get_function_arguments' method.
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 14 Sep 2016 15:53:09 +0530

> - Put the first argument on a new line as well.

​It seems fine except the case when there are no arguments, the closing
bracket ends in next line. Is it ok?

> Please double-check I didn't break anything that I've missed!
It doesn't break anything
​.​

> from

---

From: Dave Page <[email-masked]>
Date: Wed, 14 Sep 2016 11:25:44 +0100

On Wed, Sep 14, 2016 at 11:23 AM, Surinder Kumar
<[email-masked]> wrote:
> It seems fine except the case when there are no arguments, the closing

I'm not overly upset by it :-). If it irks you, feel free to change it!

> It doesn't break anything

Cool, thanks.