Subject: pgAdmin4 and boolean columns

From: "Nigel Tucker" <[email-masked]>
Date: Wed, 31 May 2017 09:30:38 +1200

Hi,

pgAdmin4 has difficulty with setting or changing Boolean check boxes in
Windows 10.

Double clicking on a Boolean cell initially null converts the display to an
empty box, which on leaving that cell displays 'false'.

If you return to the box and click once on it, it switches to a ticked box -
which on leaving the cell shows 'null'.

If however you double click on the cell, it converts to a ticked box which
on leaving the cell shows true.

So - the mechanism for converting a Boolean cell from true to false requires
five button presses, and from false to true requires four button presses.
This has to be excessive and makes direct editing any number of rows a real
pain.

Cheers

Nigel

Dr Nigel Tucker

System Architect

Specialised Structures NZ

Telephone Direct (NZ) +64 (0) 3 482 2473

                        SS with Custom

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 31 May 2017 10:35:17 +0530

Hi Nigel,

Please log the issue here <https://redmine.postgresql.org/projects/pgadmin4>
so that it can be tracked.
https://redmine.postgresql.org/projects/pgadmin4

Thanks
Surinder

On Wed, May 31, 2017 at 3:00 AM, Nigel Tucker <
[email-masked]> wrote:

> Double clicking on a Boolean cell initially null converts the display to
> an empty box, which on leaving that cell displays ‘false’.
>
> If you return to the box and click once on it, it switches to a ticked box
> – which on leaving the cell shows ‘null’.
>
> So – the mechanism for converting a Boolean cell from true to false
> requires five button presses, and from false to true requires four button
> presses. This has to be excessive and makes direct editing any number of
> rows a real pain.
>
>
>
> Cheers
>
>
>
> Nigel
>
>
>
> *Dr Nigel Tucker*
>
> System Architect
>

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 31 May 2017 11:43:01 +0530

Hi Nigel,

​Already a similar issue RM2218 <https://redmine.postgresql.org/issues/2218>
logged which is resolved.

Also, which version of pgAdmin4 you are using ?

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 31 May 2017 14:55:54 +0530

Adding pgadmin-hackers

On Wed, May 31, 2017 at 2:43 PM, Nigel Tucker <[email-masked]
o.nz> wrote:

> Hi Surindar – nice to talk!
>
>
>
> Yep – I’m running 1.5 at present – the issue RM2218 sounds similar but
> isn’t actually the same – my issue was related to the number of times you
> have to select the Boolean cell to make it change. For instance if you
> select it three times rather than four it reverts to null.
>
>
>
> I just assume the intended action is that it starts as a default (maybe
> null); a single mouse click changes it to false, and a further mouse click
> change it to true, and then repeated mouse clicks toggle round the  three
> options – if of course null is a possible default for that cell.
>
>
>
> If the cell is NOT NULL by definition, the default should be false and it
> will just toggle between true and false.
>
>
>
> Cheers
>
>
>
> Nigel
>
>
>
>
>
>
>
> *Dr Nigel Tucker*
>
> System Architect
>
> *From:* [email-masked] [mailto:
> [email-masked]] *On Behalf Of *Surinder Kumar
> *Sent:* Wednesday, 31 May 2017 6:13 PM
> *To:* Nigel Tucker
> *Cc:* pgAdmin Support
> *Subject:* Re: [pgadmin-support] pgAdmin4 and boolean columns
>
>
>
> Hi Nigel,
>
>
>
> ​Already a similar issue RM2218
> <https://redmine.postgresql.org/issues/2218> logged which is resolved.
>
>
>

---

From: Dave Page <[email-masked]>
Date: Wed, 31 May 2017 10:32:00 +0100

Yeah, this problem annoyed me last week. It seems the checkbox value
doesn't cycle consistently; it should always go false -> true -> null ->
..., but I think what it was doing was current value -> false -> true ->
null or similar, so it could take 3 clicks to get to null.

(the ordering above may be wrong, but you get the point I hope).

Please fix :-)

On Wed, May 31, 2017 at 10:25 AM, Surinder Kumar <
[email-masked]> wrote:

> Adding pgadmin-hackers
>
> On Wed, May 31, 2017 at 2:43 PM, Nigel Tucker <
>> Telephone Direct (NZ) +64 (0) 3 482 2473 <+64%203-482%202473>
>>
>>
>>
>>
>>
>>
>> If you return to the box and click once on it, it switches to a ticked
>> box – which on leaving the cell shows ‘null’.
>>
>> If however you double click on the cell, it converts to a ticked box
>> which on leaving the cell shows true.
>>
>>
>>
>> Telephone Direct (NZ) +64 (0) 3 482 2473 <+64%203-482%202473>
>>
>>
>>
>>
>>
>>
>>
>>
>
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company