Subject: [pgAdmin4][Patch]: Tables Sub nodes(Columns, Indexes, rules & triggers) Patch

From: Surinder Kumar <[email-masked]>
Date: Wed, 23 Mar 2016 21:14:31 +0530

Hi,

This patch contains following nodes:
1. Columns
2. Indexes
3  Rule
4. Trigger

I am using murtuza's patch with little changes to show above nodes under *view
and materialized view.*

This patch is only for *Tables sub node*. @murtuaza is working on table
node which is not completed.

*Note*: Please apply patch for utility function "Added Utility functions
for triggers node and rules node" first then apply this patch.

Please review it.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Surinder Kumar <[email-masked]>
Date: Thu, 7 Apr 2016 14:24:14 +0530

Hi,

PFA updated patch with couple of changes which are following:

   1. Couldn't create new Rule because model's field *view* is passed
   undefined. Now it is fixed.
   2. Removed trailing whitespaces from code.

Please review the patch.