Subject: [pgAdmin4][Patch]: RM1171 - Fix IE caching issue

From: Surinder Kumar <[email-masked]>
Date: Tue, 20 Sep 2016 19:16:41 +0530

Hi

*Issue:*
IE always caching the response data returned from the server and when same
request is made for next time, it doesn't bring new data, instead it use
cached data.

*Solution:*
Set cache to '*no-cache*' in response headers while sending from the server
side. This prevents browser from caching data every time an http request is
made.

Thanks to Harshal & Murtaza for discussing issue and solution.

Please find attached patch and review.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Surinder Kumar <[email-masked]>
Date: Tue, 20 Sep 2016 19:25:56 +0530

This patch has some issue in chrome while loading nodes. I will send
updated patch.

On Tue, Sep 20, 2016 at 7:16 PM, Surinder Kumar <
[email-masked]> wrote:

> Set cache to '*no-cache*' in response headers while sending from the
> server side. This prevents browser from caching data every time an http
> request is made.
>

---

From: Surinder Kumar <[email-masked]>
Date: Tue, 20 Sep 2016 19:28:55 +0530

Missed method closing parenthesis while calling

Please find updated patch

On Tue, Sep 20, 2016 at 7:25 PM, Surinder Kumar <
[email-masked]> wrote:

>> IE always caching the response data returned from the server and when
>> same request is made for next time, it doesn't bring new data, instead it
>> use cached data.
>>
>> *Solution:*

---

From: Dave Page <[email-masked]>
Date: Wed, 21 Sep 2016 13:29:59 +0100

Can you rebase please?

piranha:web dpage$ git apply ~/Downloads/RM1171_v1.patch
error: patch failed: web/pgadmin/utils/ajax.py:29
error: web/pgadmin/utils/ajax.py: patch does not apply

On Tue, Sep 20, 2016 at 2:58 PM, Surinder Kumar
<[email-masked]> wrote:
> On Tue, Sep 20, 2016 at 7:25 PM, Surinder Kumar
> <[email-masked]> wrote:
>>
>> On Tue, Sep 20, 2016 at 7:16 PM, Surinder Kumar
>> <[email-masked]> wrote:
>>>
>>> Hi
>>>
>>> Issue:
>>> Solution:
>>> Set cache to 'no-cache' in response headers while sending from the server

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 21 Sep 2016 19:10:35 +0530

​Hi

I did git pull and applied the patch without any error.​ I have attached
updated patch.
Please apply this patch and let me know if any issue.

---

From: Dave Page <[email-masked]>
Date: Wed, 21 Sep 2016 16:19:01 +0100

Thanks, applied.

On Wed, Sep 21, 2016 at 2:40 PM, Surinder Kumar
<[email-masked]> wrote:
> Hi
>
> I did git pull and applied the patch without any error. I have attached
> updated patch.