Subject: [pgAdmin4][Patch]: Render data grid only if Dashboard Panel is active

From: Surinder Kumar <[email-masked]>
Date: Wed, 13 Jul 2016 12:17:26 +0530

Hi

In Dashboard, the ajax calls to *render data grid* should only made, if
dashboard panel is active.
Currently it make ajax calls even if other panels like properties, sql are
active.

Please find attached patch and review.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Wed, 13 Jul 2016 08:02:23 +0100

Won't this result in incorrect graphs? I.e. chunks of data being missing (but not obviously so)?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK:http://www.enterprisedb.com
The Enterprise PostgreSQL Company

> On 13 Jul 2016, at 07:47, Surinder Kumar <[email-masked]> wrote:
> 
> Hi
> 
> In Dashboard, the ajax calls to render data grid should only made, if dashboard panel is active.
> Currently it make ajax calls even if other panels like properties, sql are active.
> 
> <dashboard_render_if_panel_is_opened.patch>
> 
> --

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 13 Jul 2016 12:41:38 +0530

> Won't this result in incorrect graphs? I.e. chunks of data being missing
 Oh I see.. It might result in incorrect graphs..
Please ignore the patch.