Subject: [pgAdmin][RM5091] Option to hide Statistics, Dependencies, Dependants tab

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 2 Feb 2021 17:43:31 +0530

Hi Hackers,

Attached patch will allow closing Statistics, Dependencies, Dependants
tabs. The tabs can be added back by right clicking on the tab strip and
selecting "Add panel", similar to that of Dashboard.
Changes are also made to make sure statistics, dependencies, dependants are
fetched only when they're visible, to avoid unnecessary ajax calls.

Please review.

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 3 Feb 2021 12:59:56 +0530

Thanks, patch applied.

On Tue, Feb 2, 2021 at 5:44 PM Aditya Toshniwal <
[email-masked]> wrote:

> Changes are also made to make sure statistics, dependencies, dependants
> are fetched only when they're visible, to avoid unnecessary ajax calls.
>
> Please review.
>
> --
> Thanks,
> Aditya Toshniwal

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 8 Feb 2021 17:38:40 +0530

Hi,

The changes for not calling the ajax until the panel is focused were missed
in the last patch. Please review the attached.

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 9 Feb 2021 12:40:59 +0530

Hi Aditya

Please fix the issue for Dashboard API calls as well and send the patch
again.

On Mon, Feb 8, 2021 at 5:39 PM Aditya Toshniwal <
[email-masked]> wrote:

> Hi,
>
> The changes for not calling the ajax until the panel is focused were
> missed in the last patch. Please review the attached.
>

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 9 Feb 2021 14:22:35 +0530

Hello Akshay,

The previous patch will fix the dashboard issue also.

On Tue, Feb 9, 2021 at 12:41 PM Akshay Joshi <[email-masked]>
wrote:

>> On Wed, Feb 3, 2021 at 1:00 PM Akshay Joshi <
>> [email-masked]> wrote:
>>
>>> Thanks, patch applied.
>>>

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 9 Feb 2021 16:33:51 +0530

Thanks, patch applied.

On Tue, Feb 9, 2021 at 2:23 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Tue, Feb 9, 2021 at 12:41 PM Akshay Joshi <
>>>>> Changes are also made to make sure statistics, dependencies,
>>>>> dependants are fetched only when they're visible, to avoid
>>>>> unnecessary ajax calls.
>>>>>
>>>>> Please review.
>>>>>
>>>>> --
>>>>> Thanks,
>>>>> Aditya Toshniwal