Subject: pgAdmin: ERD Tool a suggestion.

From: Hitesh Patel <[email-masked]>
Date: Wed, 3 Feb 2021 15:11:27 +0000

Dear pgAdmin Hackers,

I notice in the latest version of pgAdmin (4.30) there is a ERD beta tool. 

I wanted to suggest a feature which would be most helpful for database developers (not sure if you already working on this).

A lot of times I need to propose changes to the database and the database has 100s of table, which becomes very difficult to view altogether.

What I was looking to suggest is to connect to an existing database, but then be able to select existing ‘database table(s)’, with the ‘ERD tool’ then able to create all the links/attribute info in the view. So bit like ‘Generate ERD, but allow me to choose/restrict the tables’. This allows me to generate ‘different perspectives’ of my database and focus on the functionality they deliver in discussion/proposals/documentation.

Kinds Regards,

Hitesh Patel
PS: very excited with this feature.

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 4 Feb 2021 11:12:05 +0530

Hi Hitesh,

On Wed, Feb 3, 2021 at 8:55 PM Hitesh Patel <[email-masked]> wrote:

> I wanted to suggest a feature which would be most helpful for database
> developers (not sure if you already working on this).
>
> A lot of times I need to propose changes to the database and the database
> has 100s of table, which becomes very difficult to view altogether.
>
> What I was looking to suggest is to connect to an existing database, but
> then be able to select existing ‘database table(s)’, with the ‘ERD tool’
> then able to create all the links/attribute info in the view. So bit like
> ‘Generate ERD, but allow me to choose/restrict the tables’. This allows me
> to generate ‘different perspectives’ of my database and focus on the
> functionality they deliver in discussion/proposals/documentation.
>
Can you please create a feature request here -
https://redmine.postgresql.org/projects/pgadmin4/issues/new ?

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"