Subject: pgAdmin Docker gunicorn configurable --access-logfile

From: Seweryn Zeman <[email-masked]>
Date: Mon, 18 Nov 2019 12:29:32 +0100

Hi, me and my company is working with pgAdmin since we decided to use pgSql – mostly for development with containers. In this case Docker. While starting a docker-compose in dev mode with pgAdmin in stack we can see lots of access logs for HTTP and WS which are very irrelevant to us. This makes important logs to disappear.

Current Docker entrypoint is having launch command set to...

exec gunicorn ... --access-logfile - run_pgadmin:app

…with some parameters easily configurable via env vars.

My proposal is to also make --access-logfile configurable, like:

--access-logfile ${GUNICORN_ACCESS_LOGFILE:--}

This preserves 100% backward compability and allows users like us to set GUNICORN_ACCESS_LOGFILE=None or another file or stdout of particular PID.

--
Seweryn Zeman
CTO, Jazzy Innovations

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 18 Nov 2019 17:35:21 +0530

Hi Seweryn,

Kindly raise a feature request here -
https://redmine.postgresql.org/projects/pgadmin4/issues/new

On Mon, Nov 18, 2019 at 4:59 PM Seweryn Zeman <[email-masked]>
wrote:

> Hi, me and my company is working with pgAdmin since we decided to use
> pgSql – mostly for development with containers. In this case Docker. While
> starting a docker-compose in dev mode with pgAdmin in stack we can see lots
> of access logs for HTTP and WS which are very irrelevant to us. This makes
> important logs to disappear.
>
> This preserves 100% backward compability and allows users like us to set
> GUNICORN_ACCESS_LOGFILE=None or another file or stdout of particular PID.
>
> --
> Seweryn Zeman
> CTO, Jazzy Innovations
>

-- 
Thanks and Regards,
Aditya Toshniwal
Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"