Subject: [pgAdmin][RM4329] Initialization error when parameterised functions debugged in parallel in two separate tabs

From: Aditya Toshniwal <[email-masked]>
Date: Fri, 7 Jun 2019 12:20:58 +0530

Hi Hackers,

Attached is the patch for debugger improvements. The changes include:
1) Change the way debug info is stored in session. Removed redundant
session related code in debugger code. All the session related handling
done at one place.
2) Fixed a bug where debugger was not opening for EPAS package function.
3) If a package is defined without body and we try to debug a proc/func,
the debugger opened a blank window. Changes made so that it will throw
error as "XYZ is not defined in package body."

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 10 Jun 2019 12:58:03 +0530

Hi Aditya

Following are the review comments:

   - "Set breakpoint" option not working, when click it throws an error.
   - Create an empty function and try to debug that. It should show proper
   error message.
   - Got the following backend error when closing the connection, please
   fix this:
      -     File
      "E:\Projects\pgadmin4\web\pgadmin\tools\debugger\__init__.py", line 2053,
      in close_debugger_session
          conn_id=dbg_obj['exe_conn_id'])

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 10 Jun 2019 18:27:48 +0530

Hi Hackers,

Attached is the updated patch with fixes.

On Mon, Jun 10, 2019 at 12:58 PM Akshay Joshi <[email-masked]>
wrote:

> Fixed.

>
>    - Create an empty function and try to debug that. It should show
>    proper error message.
>
> This seems to be a bug in the debugger itself. I'll raise a bug with
simulation steps if it is. But, not sure where to raise.

> Fixed.

---

From: Dave Page <[email-masked]>
Date: Mon, 10 Jun 2019 14:58:20 +0100

Thanks, patch applied.

On Mon, Jun 10, 2019 at 1:58 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Mon, Jun 10, 2019 at 12:58 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Aditya
>>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Aditya Toshniwal <[email-masked]>
Date: Fri, 14 Jun 2019 15:07:28 +0530

Hi Hackers,

I have missed a line while implementing this. Attached is the patch to fix
that.
Although it has not caused any trouble, but still it should be changed.
Kindly review.

On Mon, Jun 10, 2019 at 7:28 PM Dave Page <[email-masked]> wrote:

>>>    - Got the following backend error when closing the connection,
>>>    please fix this:
>>>       -     File
>>>> 3) If a package is defined without body and we try to debug a
>>>> proc/func, the debugger opened a blank window. Changes made so that it will
>>>> throw error as "XYZ is not defined in package body."
>>>>
>>>> --
>>>> Thanks and Regards,
>>>> Aditya Toshniwal

---

From: Dave Page <[email-masked]>
Date: Fri, 14 Jun 2019 12:47:00 +0100

Thanks, applied.

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 19 Jun 2019 12:34:58 +0530

Hi,

This is not working on Python 2.7 :(
Attached patch will add an __init__ file in the utils directory under
debugger to make it work with python 2.7

On Fri, Jun 14, 2019 at 5:17 PM Dave Page <[email-masked]> wrote:

>> I have missed a line while implementing this. Attached is the patch to
>> fix that.

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 19 Jun 2019 13:32:18 +0530

Thanks patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*