Subject: [pgAdmin][RM4993] [Accessibility] Read-only controls and disabled controls needs to be separately identified

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 22 Jan 2020 17:45:53 +0530

Hi Hackers,

Attached is the patch to allow input controls to be set as readonly instead
of disabled.
I've also changed the code for the nodes to make sure properties tab have
readonly fields wherever applicable. This will allow tab navigation in
properties tab and also allow screen readers to read it.
Please note that, I've not visited each and every node create/edit dialog
to identify what should be readonly or what should be disabled as it
depends on business logic. The patch is mainly for the properties tab.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
pgAdmin Hacker | Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 23 Jan 2020 13:06:13 +0530

Hi Aditya

On Wed, Jan 22, 2020 at 5:46 PM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Hackers,
>
> Attached is the patch to allow input controls to be set as readonly
> instead of disabled.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 23 Jan 2020 13:08:01 +0530

Hi Aditya

As per discussion, we should visit all the nodes create/edit dialog and
make the controls read-only wherever appropriate.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 30 Jan 2020 13:55:13 +0530

Hi Hackers,

Attached is the updated patch to include dialogs (create/edit) for all the
nodes.
Kindly review.

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 31 Jan 2020 12:38:18 +0530

Thanks, patch applied.

On Thu, Jan 30, 2020 at 1:55 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Thu, Jan 23, 2020 at 1:08 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Aditya
>>
>>> I've also changed the code for the nodes to make sure properties tab
>>> have readonly fields wherever applicable. This will allow tab navigation in
>>> Please note that, I've not visited each and every node create/edit
>>> dialog to identify what should be readonly or what should be disabled as it

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Nagesh Dhope <[email-masked]>
Date: Fri, 6 Mar 2020 12:20:50 +0530

Hi Akshay,
Please find a patch to make controls under *Active query details* subnode
read-only on the dashboard.

On Fri, Jan 31, 2020 at 12:38 PM Akshay Joshi <[email-masked]>
wrote:

>> Attached is the updated patch to include dialogs (create/edit) for all
>> the nodes.
>> Kindly review.
>>

-- 
Thanks,
Nagesh

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 6 Mar 2020 18:00:26 +0530

Thanks, patch applied.

On Fri, Mar 6, 2020 at 12:21 PM Nagesh Dhope <[email-masked]>
wrote:

> On Fri, Jan 31, 2020 at 12:38 PM Akshay Joshi <

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*