Subject: [pgAdmin][RM4764][Accessibility] Allow screen-reader to read relationship attributes in nested elements

From: Aditya Toshniwal <[email-masked]>
Date: Fri, 13 Dec 2019 12:09:09 +0530

Hi Hackers,

Attached is the patch to:
1) Read relationship for tab, tabpanels and tables under it. Similar
changes are done for subnode controls.
2) Add role="img" for font icons, per -
https://www.w3.org/WAI/WCAG21/Techniques/aria/ARIA24.html

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 17 Dec 2019 13:25:16 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Ganesh Jaybhay <[email-masked]>
Date: Wed, 11 Mar 2020 14:43:20 +0530

Hi Hackers,

Attached is the patch on top of initial patch for:

   - screen reader to read elements in radio modern control
   - minor accessibility(aria-label) additions at few missing places
   - Radiocontrol to have different ids for each options

Please review.

Regards,
Ganesh Jaybhay

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 12 Mar 2020 11:18:57 +0530

Thanks, patch applied.

On Wed, Mar 11, 2020 at 2:43 PM Ganesh Jaybhay <
[email-masked]> wrote:

> On Tue, Dec 17, 2019 at 1:25 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Thanks, patch applied.
>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*