Subject: [pgAdmin][RM4842] trigger/compound trigger on a partitioned table

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 25 Dec 2019 16:59:11 +0530

Hi Hackers,

Attached is the patch to fix the issue where it was not possible to add
constraints, index, rules, triggers and compound triggers on child tables
of a partitioned table.
The problem was with URLs formed which also included parent table OID,
which was not needed. The code is changed to add "url_jump_after_node"
param to skip after a certain node, which will will skip all the value
between jump_after_node to the last node, excluding jump_after_node and the
last node. Partitioned table itself is a "table" and can be multilevel.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
pgAdmin Hacker | Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 31 Dec 2019 13:27:50 +0530

Hi Aditya

I have applied the patch and found one issue collection nodes are visible
twice under the child node of the partition table. Please fix that.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 1 Jan 2020 11:58:23 +0530

Hi Akshay,

> twice under the child node of the partition table. Please fix that.
I tried to simulate this. But I'm not facing issue. Can you please verify
once again ?

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 1 Jan 2020 13:12:44 +0530

Hi Aditya

I have removed the generated folder and it works. Thanks, patch applied.

On Wed, Jan 1, 2020 at 11:58 AM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Akshay,
>
> On Tue, Dec 31, 2019 at 1:28 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Aditya
>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*