Subject: OpenStreetMap not showing in geometry viewer

From: Charles Wang <[email-masked]>
Date: Fri, 28 Feb 2020 15:51:03 -0800

Hi Guys,
I've spent two days on this and still have no clue....
The openstreetmap basemap only worked once at the first try of pgadmin.
And it only worked for one database.
I tried it on the second database it didn't work: no openstreetmap shown up.

I reinstalled it (macos), and it still didn't work for any database that I
connected to.

I tried different browsers, cleared all browsers histories and cache.
I even tried to fire up pgadmin in a container, but the openstreetmap base
map is still missing in the geometry viewer.

where is osm, any idea? Thanks.

BRGDS,
Charles

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 2 Mar 2020 11:18:59 +0530

Hi Charles,

It looks like the SRID for your geometry column is different from 4326 (You
need to explore on your own what is SRID)
Use https://postgis.net/docs/Find_SRID.html to get your SRID and try
converting it to 4326(if not 4326) using
https://postgis.net/docs/UpdateGeometrySRID.html

-- 
Thanks and Regards,
Aditya Toshniwal
pgAdmin Hacker | Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Charles Wang <[email-masked]>
Date: Sun, 1 Mar 2020 22:51:47 -0800

Thank you Aditya, exactly! you made my day.
I appreciate your help.

BRGDS,
Charles

On Sun, Mar 1, 2020 at 9:49 PM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Charles,
>
> It looks like the SRID for your geometry column is different from 4326
> (You need to explore on your own what is SRID)
>> I reinstalled it (macos), and it still didn't work for any database that
>> I connected to.
>>
>> I even tried to fire up pgadmin in a container, but the openstreetmap
>> base map is still missing in the geometry viewer.
>>

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 2 Mar 2020 12:38:17 +0530

> Thank you Aditya, exactly! you made my day.
Glad it worked !! :)