Subject: [pgAdmin][RM4938] Code refactoring of 'Columns' node

From: Akshay Joshi <[email-masked]>
Date: Wed, 27 Nov 2019 14:25:16 +0530

Hi Hackers,

Attached is the patch contains following fixes:

   - RM #4938 Code refactoring of 'Columns' node.
   - RM #4761 Wrong type when changing timestamp with time zone to
   timestamp without a time zone.
   - RM #4964 Column length is not being removed through the properties of
   any table.
   - RM #4965 Interval data type is not displayed in the properties section
   of a table>columns.
   - Change the label from 'Length and Precision' to 'Length/Precision and
   Scale' for columns.
   - The maximum length for datatype like interval, timestamp with time
   zone, time with time zone, etc.. is 6. Set the max length to 6 instead of
   10.

Please review and test it from the table and column dialogs.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 28 Nov 2019 17:46:37 +0530

Hi Akshay,

The patch looks good to me. Test cases are passing.
I had found one issue, but it was not related to your patch so I've logged
it in redmine.
Apart from that, I've changed column.js code slightly to handle min_val and
max_val for length and precision correctly.
Attached is the updated patch.

On Wed, Nov 27, 2019 at 2:25 PM Akshay Joshi <[email-masked]>
wrote:

>    - RM #4964 Column length is not being removed through the properties
>    of any table.
>    - RM #4965 Interval data type is not displayed in the properties
>    section of a table>columns.
>    - Change the label from 'Length and Precision' to 'Length/Precision
>    and Scale' for columns.

-- 
Thanks and Regards,
Aditya Toshniwal
Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"