Subject: pgAdmin 4 - gettext usage fixes

From: "Libor M." <[email-masked]>
Date: Sun, 22 Mar 2020 11:55:19 +0100

Hello,
I fixed using gettext function and add more usages for translations,
specifically:

- fixed usage gettext('') instead of _('') in javascript files
- fixed usage gettext('') instead of `${gettext('')}` in javascript
files, because "pybabel extract" not support extracting from this
syntax
- added a lot of gettext for support translations

Diff file is attached.

Best regards,

Libor M.

E-mail: [email-masked]
GitHub: https://github.com/liborm85

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 23 Mar 2020 16:00:21 +0530

Hi Aditya

Can you please review this?

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 23 Mar 2020 20:31:33 +0530

Hi Libor,

Thank you for the patch. It is good clean up patch.
I've made a few changes in the patch. You've imported sprintf which was not
required since gettext also works as sprintf directly.
I've also created a housekeeping redmine ticket to track it -
https://redmine.postgresql.org/issues/5284

The messages compile fine. The patch can be committed.
Please find the attached updated patch.

-- 
Thanks and Regards,
Aditya Toshniwal
pgAdmin Hacker | Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 24 Mar 2020 11:05:56 +0530

Hi Hackers,

Please find the updated patch with pep8, linter issues fixed.

On Mon, Mar 23, 2020 at 8:31 PM Aditya Toshniwal <
[email-masked]> wrote:

> I've made a few changes in the patch. You've imported sprintf which was
> not required since gettext also works as sprintf directly.
> On Mon, Mar 23, 2020 at 4:00 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Aditya
>>

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 24 Mar 2020 11:15:27 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*