Subject: [pgAdmin][RM4351] Confirm before close of properties dialog if changes not saved

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 29 Oct 2019 12:09:58 +0530

Hi Hackers,

Attached is the patch to warn the user before closing an unsaved properties
dialog.
Additionally, I have added a preference option in Browser->Display where
the user can disable this. Default is enabled.
Docs updated.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Dave Page <[email-masked]>
Date: Tue, 29 Oct 2019 14:35:23 +0000

Thanks, applied.

On Tue, Oct 29, 2019 at 6:40 AM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Hackers,
>
> Attached is the patch to warn the user before closing an unsaved
> properties dialog.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Dave Page <[email-masked]>
Date: Tue, 29 Oct 2019 15:31:11 +0000

Hi

I just found an, umm, embarrassing issue with this. It asks for the cancel
confirmation even when pressing the OK button :-o

Can you fix that ASAP please?

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 30 Oct 2019 10:09:50 +0530

Hi,

> confirmation even when pressing the OK button :-o
Tested all but missed the obvious. Bad miss :/
Attached is the patch to fix the issue.

---

From: Dave Page <[email-masked]>
Date: Wed, 30 Oct 2019 10:14:00 +0000

Hi

On Wed, Oct 30, 2019 at 4:40 AM Aditya Toshniwal <
[email-masked]> wrote:

>> I just found an, umm, embarrassing issue with this. It asks for the
>> cancel confirmation even when pressing the OK button :-o
>>

Thanks - applied. Should we also warn on Reset? That seems logical to me.

>>>> Additionally, I have added a preference option in Browser->Display
>>>> where the user can disable this. Default is enabled.
>>>> Docs updated.
>>>>
>>>> Kindly review.
>>>>
>>>> --
>>>> Thanks and Regards,
>>>> Aditya Toshniwal

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 30 Oct 2019 18:24:18 +0530

> Thanks - applied. Should we also warn on Reset? That seems logical to me.
Can be added. Preference option should be common for both Cancel and Reset.
Will send an add-on patch for this.

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 4 Nov 2019 17:15:14 +0530

Hi Hackers,

As discussed, extending the changes to Reset button also. Warning will
appear for Reset button now if opted in preferences and changes are not
saved.
Note that, the preference option is same for Close and Reset button.

Kindly review.

On Wed, Oct 30, 2019 at 6:24 PM Aditya Toshniwal <
[email-masked]> wrote:

> Can be added. Preference option should be common for both Cancel and
> Reset. Will send an add-on patch for this.
>
>>
>>
>>>

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 5 Nov 2019 11:01:16 +0530

Hi Aditya

I have tested it. Reset functionality not working when preference setting
is set to False. Please fix and resend the patch.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 5 Nov 2019 12:45:25 +0530

Hi,

Please find the attached updated patch.

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 5 Nov 2019 14:28:58 +0530

Thanks, patch applied.

On Tue, Nov 5, 2019 at 12:46 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Tue, Nov 5, 2019 at 11:01 AM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Aditya
>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*