Subject: [pgAdmin][RM5227] Cannot add user

From: Aditya Toshniwal <[email-masked]>
Date: Fri, 10 Apr 2020 10:32:17 +0530

Hi Hackers,

Attached is the patch to fix following user management related issues:
1) Unable to add a user when there are many users. The dialog went blank.
Fixed.
2) Error message did not have a close button. Fixed.
3) When clicked on the add button, then cursor will focus on the email box
of the new row for convenience.
4) When the dialog opens, the cursor will focus on the search text box.
5) By default, "User" role will be selected when adding a new user. Also
removed an empty option in the roles dropdown.
6) When the search filter is applied and we try to add an already existing
user, the validation is done only on the filtered data and not on all the
users data. This is fixed.

Please review.

-- 
Thanks and Regards,
Aditya Toshniwal
pgAdmin Hacker | Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 10 Apr 2020 15:12:59 +0530

Hi Aditya

Can you please rebase and send the patch again.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Fri, 10 Apr 2020 16:10:48 +0530

Hi Hackers,

Attached is the updated rebased patch.

On Fri, Apr 10, 2020 at 3:13 PM Akshay Joshi <[email-masked]>
wrote:

>> 3) When clicked on the add button, then cursor will focus on the email
>> box of the new row for convenience.
>> 6) When the search filter is applied and we try to add an already
>> existing user, the validation is done only on the filtered data and not on
>> all the users data. This is fixed.
>>
>> Please review.
>>
>> --
>> Thanks and Regards,
>> Aditya Toshniwal

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 10 Apr 2020 17:37:39 +0530

Thanks, patch applied.

On Fri, Apr 10, 2020 at 4:11 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Fri, Apr 10, 2020 at 3:13 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Aditya
>>
>>> 1) Unable to add a user when there are many users. The dialog went
>>> blank. Fixed.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*