Subject: Error [99] reset password

From: Zahid Rahman <[email-masked]>
Date: Wed, 18 Dec 2019 20:51:17 +0000

I did reset my port 25 "sudo ufw allow 25"
but made no diff. Which port is expect ? Thanks.

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 19 Dec 2019 10:22:06 +0530

Hi Zahid,

You need to configure the pgAdmin SMTP params by creating config_local.py
and changing

MAIL_SERVER = 'localhost'
MAIL_PORT = 25
MAIL_USE_SSL = False
MAIL_USE_TLS = False
MAIL_USERNAME = ''
MAIL_PASSWORD = ''
MAIL_DEBUG = False

Ref  https://www.pgadmin.org/docs/pgadmin4/4.16/config_py.html for
config_local.py.

-- 
Thanks and Regards,
Aditya Toshniwal
pgAdmin Hacker | Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Zahid Rahman <[email-masked]>
Date: Thu, 19 Dec 2019 06:23:47 +0000

Hi,

 created file config_local.py --> rebooted --> no change

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 19 Dec 2019 12:02:25 +0530

Hi Zahid,

You need to configure it. It will not work as it is obviously. :)
Set the mail server, username, password for the reset password mail to
trigger. Below is the example to use Gmail.

MAIL_SERVER = 'smtp.gmail.com'
MAIL_PORT = 465
MAIL_USE_SSL = True
MAIL_USERNAME = '<you email>@gmail.com'
MAIL_PASSWORD = '<your password>'
MAIL_DEBUG = False

---

From: Zahid Rahman <[email-masked]>
Date: Thu, 19 Dec 2019 08:09:02 +0000

I set the password to  PGADMIN_DEFAULT_PASSWORD *and* my gmail account
password in config_local.py, still same outcome.
sudo docker run -p 80:80 -e 'PGADMIN_DEFAULT_EMAIL=[email-masked]' -e
'PGADMIN_DEFAULT_PASSWORD=sunrise' -d dpage/pgadmin4
I also restarted docker each time I changed config_local.py

On Thu, 19 Dec 2019 at 06:33, Aditya Toshniwal <
[email-masked]> wrote:

>>> You need to configure the pgAdmin SMTP params by creating
>>> config_local.py and changing
>>>

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 19 Dec 2019 13:51:13 +0530

Hi Zahid,

Google has some way to generate app password which you can use for SMTP.
Also check it your internet is working.

On Thu, Dec 19, 2019, 13:39 Zahid Rahman <[email-masked]> wrote:

> sudo docker run -p 80:80 -e 'PGADMIN_DEFAULT_EMAIL=[email-masked]'
> -e 'PGADMIN_DEFAULT_PASSWORD=sunrise' -d dpage/pgadmin4

---

From: Zahid Rahman <[email-masked]>
Date: Thu, 19 Dec 2019 11:19:25 +0000

Is this the expected page ?

---

From: Zahid Rahman <[email-masked]>
Date: Thu, 19 Dec 2019 14:31:08 +0000

This page is displaying strange and inconsistent behaviour.
when I choose the option recover password the  reset_password page  doesn't
displaying in reasonable time but 10 minutes later. Two images of one page
attached below as you see is different than previous image. This
reset_password page only appeared after I rebooted making no changes to
PGADMIN4 It needs investigating.