Subject: [pgAdmin4][Patch] - RM 3664 - Statistic panel hangs when 1000+ tables

From: Khushboo Vashi <[email-masked]>
Date: Thu, 17 Jan 2019 11:35:48 +0530

Hi,

Please find the attached patch to fix the RM 3664 - Statistic panel hangs
when 1000+ tables

The statistics tab hangs with more rows. So, now the rows will be pushed in
the backgrid collection in bunches on scroll event to fix this issue.

Thanks,
Khushboo

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 21 Jan 2019 16:42:54 +0530

Hi Aditya

Can you please review it.

On Thu, Jan 17, 2019 at 11:36 AM Khushboo Vashi <
[email-masked]> wrote:

> The statistics tab hangs with more rows. So, now the rows will be pushed
> in the backgrid collection in bunches on scroll event to fix this issue.
>
> Thanks,
> Khushboo
>

-- 
*Akshay Joshi*

*Sr. Software Architect *

*Phone: +91 20-3058-9517Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 22 Jan 2019 17:05:21 +0530

Hi Khushboo,

There is improvement than before but the UI still lags. I tested with 2000
tables and statistics on Tables node.
I would also suggest to add further rows only if scrolling down. Rows
adding can be avoided even if the scroll does not take to the last element.
Currently, if I scroll slightly down it add rows and if I scroll back up it
adds more. I think the scroll up fetch can be avoided.

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB Software Solutions | Pune
"Don't Complain about Heat, Plant a tree"

---

From: Khushboo Vashi <[email-masked]>
Date: Tue, 29 Jan 2019 15:17:05 +0530

Hi,

Please find the attached updated patch.
I have also improved the performance of the properties tab.
Please also apply the bootstrap toggle patch to check the properties tab
performance.

Thanks,
Khushboo

On Tue, Jan 22, 2019 at 5:05 PM Aditya Toshniwal <
[email-masked]> wrote:

> Currently, if I scroll slightly down it add rows and if I scroll back up
> it adds more. I think the scroll up fetch can be avoided.
>
> On Mon, Jan 21, 2019 at 4:43 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Aditya
>>
>>> Please find the attached patch to fix the RM 3664 - Statistic panel
>>> hangs when 1000+ tables
>>>

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 31 Jan 2019 14:26:44 +0530

Hi Khushboo,

The patch looks good to me and statistics works great now. Tested with 2000
tables.
However, I did not get what did the below change do.

*diff --git a/web/pgadmin/misc/statistics/static/js/statistics.js
b/web/pgadmin/misc/statistics/static/js/statistics.js*

*index cfd573e1..5441f883 100644*

*--- a/web/pgadmin/misc/statistics/static/js/statistics.js*

*+++ b/web/pgadmin/misc/statistics/static/js/statistics.js*

@@ -104,7 +104,9 @@ define('misc.statistics', [

       offText: gettext('False'),

       onColor: 'success',

       offColor: 'primary',

-      size: 'mini',

+      size: 'small',

+      width: null,

+      height: null,

     }

   );

@Committer,

Except above change, all looks good to me.

On Tue, Jan 29, 2019 at 3:17 PM Khushboo Vashi <
[email-masked]> wrote:

>> There is improvement than before but the UI still lags. I tested with
>> 2000 tables and statistics on Tables node.
>>>> The statistics tab hangs with more rows. So, now the rows will be
>>>> pushed in the backgrid collection in bunches on scroll event to fix this
>>>> issue.
>>>>
>>>> Thanks,
>>>> Khushboo
>>>>
>>>
>>>
>>> --
>>> *Akshay Joshi*
>>>

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 31 Jan 2019 14:57:52 +0530

Thanks patch applied with the mentioned changes.

On Thu, Jan 31, 2019 at 2:26 PM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Khushboo,
>
> The patch looks good to me and statistics works great now. Tested with
> 2000 tables.

-- 
*Akshay Joshi*