Subject: [pgAdmin] Fix incorrect import in setup.py

From: Azad Salahlı <[email-masked]>
Date: Thu, 24 Sep 2020 04:01:46 -0400

Hi,

First time posting here. I've attached a fix for an incorrect import
in `setup.py`. Trying to import from `pgadmin` before adding the root
directory to the system path results in import error, when the script
is invoked in any other way than running it directly. For example

    $ /path/to/venv/bin/pip install pgadmin4
    $ /path/to/venv/bin/python -m pgadmin4.setup
    Traceback (most recent call last):
      ...
      File "/path/to/venv/lib/python3.6/site-packages/pgadmin4/setup.py",
line 18, in <module>
        from pgadmin.model import db, User, Version, ServerGroup, Server, \
    ModuleNotFoundError: No module named 'pgadmin'

Please let me know what you think. Happy to address any feedback.

Regards,
Azad Salahlı
diff --git a/web/setup.py b/web/setup.py
index 4cd090d15..fbc7f1e04 100644
--- a/web/setup.py
+++ b/web/setup.py
@@ -15,8 +15,6 @@ import json
 import os
 import sys
 import builtins
-from pgadmin.model import db, User, Version, ServerGroup, Server, \
-    SCHEMA_VERSION as CURRENT_SCHEMA_VERSION
 
 # Grab the SERVER_MODE if it's been set by the runtime
 if 'SERVER_MODE' in globals():
@@ -31,6 +29,8 @@ if sys.path[0] != root:
     sys.path.insert(0, root)
 
 from pgadmin import create_app
+from pgadmin.model import db, User, Version, ServerGroup, Server, \
+    SCHEMA_VERSION as CURRENT_SCHEMA_VERSION

 def add_value(attr_dict, key, value):

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 28 Sep 2020 16:48:17 +0530

Hi Azad,

The patch looks good to me.

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 28 Sep 2020 17:56:59 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*