Subject: Regarding login or reset to PGADMIN

From: vivekananda Katakam <[email-masked]>
Date: Thu, 10 Sep 2020 18:48:07 +0530

Hi All,

I have login to web based pgadmin tool remotely and in the login screen I
was unable to login or reset my password.

When reset my password i got password reset message sent to my office email
id , but i did not receive password reset mail.

I want to change my username and password. I want to know how can I change
it.

I have installed PGadmin4 tool on RHEL Linux and running remotely.

PFA attached screenshot for more info.

Can u please suggest.

Thanks and Regards,

Vivek

---

From: Aditya Toshniwal <[email-masked]>
Date: Fri, 11 Sep 2020 10:06:51 +0530

Hi Vivekananda,

You need to put the SMTP configurations in config_local.py file to make it
work. Refer -
https://www.pgadmin.org/docs/pgadmin4/4.25/config_py.html#the-config-py-file
Change -

###########################################################################
Mail server settings##########################################################################
# These settings are used when running in web server mode for
confirming# and resetting passwords etc.# See:
http://pythonhosted.org/Flask-Mail/ for more infoMAIL_SERVER =
'localhost'MAIL_PORT = 25MAIL_USE_SSL = FalseMAIL_USE_TLS =
FalseMAIL_USERNAME = ''MAIL_PASSWORD = ''MAIL_DEBUG = False

On Thu, Sep 10, 2020 at 7:03 PM vivekananda Katakam <
[email-masked]> wrote:

> When reset my password i got password reset message sent to my office
> email id , but i did not receive password reset mail.
>

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 16 Sep 2020 10:10:00 +0530

Hi Vivekananda,

I'll close the bug #5823 as it's not an issue, and it works fine for you.

On Tue, Sep 15, 2020 at 7:04 PM vivekananda Katakam <
[email-masked]> wrote:

> Hi Aditya,
>
> Thanks for the reply. Now I am able to login and reset my password.
>
> Thanks and Regards,
> Vivek
>
> On Fri, Sep 11, 2020 at 10:07 AM Aditya Toshniwal <
> [email-masked]> wrote:
>
>> Hi Vivekananda,
>>
>> You need to put the SMTP configurations in config_local.py file to make
>> it work. Refer -
>> ########################################################################### Mail server settings##########################################################################
>> # These settings are used when running in web server mode for confirming# and resetting passwords etc.# See: http://pythonhosted.org/Flask-Mail/ for more infoMAIL_SERVER = 'localhost'MAIL_PORT = 25MAIL_USE_SSL = FalseMAIL_USE_TLS = FalseMAIL_USERNAME = ''MAIL_PASSWORD = ''MAIL_DEBUG = False
>>
>>
>>
>>> I have login to web based pgadmin tool remotely and in the login screen
>>> I was unable to login or reset my password.
>>>
>>> I want to change my username and password. I want to know how can I
>>> change it.
>>>

---

From: vivekananda Katakam <[email-masked]>
Date: Sat, 19 Sep 2020 18:10:31 +0530

Hi Aditya,

Thanks. You can close the issue.

Thanks and Regards,
Vivek