Subject: [pgAdmin][RM5197] Accessibility issues of external packages

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 2 Apr 2020 16:45:32 +0530

Hi Hackers,

Attached patch will replace the existing color picker -
spectrum-colorpicker with @simonwep/pickr.
spectrum-colorpicker has accessibility issues and is not maintained since
long. @simonwep/pickr is actively maintained and the package is improving
its accessibility actively.

Please review.

-- 
Thanks and Regards,
Aditya Toshniwal
pgAdmin Hacker | Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 3 Apr 2020 17:14:41 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Fri, 5 Jun 2020 17:01:44 +0530

Hi Hackers,

Attached is the patch to update Codemirror version to latest which allows
us to set screen reader labels on Codemirror editor. This is part of #5197.
Please review.

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 8 Jun 2020 12:26:55 +0530

Thanks, patch applied.

On Fri, Jun 5, 2020 at 5:02 PM Aditya Toshniwal <
[email-masked]> wrote:

>>> spectrum-colorpicker has accessibility issues and is not maintained
>>> since long. @simonwep/pickr is actively maintained and the package is
>>> improving its accessibility actively.
>>>
>>> Please review.
>>>
>>> --
>>> Thanks and Regards,
>>> Aditya Toshniwal

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*