Subject: [pgAdmin][RM6891] Composite foreign keys in ERD

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 13 Oct 2021 12:34:25 +0530

Hi Hackers,

Please review the attached patch which adds support for composite foreign
keys in ERD.

-- 
Thanks,
Aditya Toshniwal
pgAdmin Hacker | Software Architect | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 13 Oct 2021 12:53:39 +0530

Hi Aditya

Jasmine test cases are failing after applying the patch. Can you please fix
and resend it.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 13 Oct 2021 13:52:30 +0530

Hi,

Attached is the updated patch.

On Wed, Oct 13, 2021 at 12:53 PM Akshay Joshi <[email-masked]>
wrote:

> Hi Aditya
>
> Jasmine test cases are failing after applying the patch. Can you please
> fix and resend it.
>

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 13 Oct 2021 14:29:49 +0530

Thanks, the patch applied.

On Wed, Oct 13, 2021 at 1:53 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Wed, Oct 13, 2021 at 12:53 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Aditya
>>
>>> Please review the attached patch which adds support for composite
>>> foreign keys in ERD.
>>>
>>> --
>>> Thanks,
>>> Aditya Toshniwal

---

From: Aditya Toshniwal <[email-masked]>
Date: Fri, 15 Oct 2021 16:19:24 +0530

Hi,

The patch fixes the issue where all FKs are removed if one of the multiple
FKs on the same column is removed.
Please review.

---

From: Akshay Joshi <[email-masked]>
Date: Sat, 16 Oct 2021 12:59:48 +0530

On Fri, Oct 15, 2021 at 4:20 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Wed, Oct 13, 2021 at 2:30 PM Akshay Joshi <