Subject: [pgAdmin][RM7187] ERD Image png 0 bytes

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 6 Apr 2022 18:01:21 +0530

Hi Hackers,

Due to the limitations of HTML Canvas, if the image exceeds max
width/height of 32767 then the image becomes empty.
To fix this, I have set the max limit of width and height to 32767. The ERD
diagram will be cut if it exceeds the limit. The ERD tool will also throw
an alert to inform the user in that case.
Please review.

-- 
Thanks,
Aditya Toshniwal
pgAdmin Hacker | Software Architect | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Dave Page <[email-masked]>
Date: Wed, 6 Apr 2022 13:36:53 +0100

Hi

On Wed, 6 Apr 2022 at 13:32, Aditya Toshniwal <
[email-masked]> wrote:

> To fix this, I have set the max limit of width and height to 32767. The
> ERD diagram will be cut if it exceeds the limit. The ERD tool will also
> throw an alert to inform the user in that case.
> Please review.
>
>

"The downloaded image has exceeded the maximum size of 32767 x 32767
pixels, and has been cropped to that size."

Can we similarly limit the size of the design canvas? 32767 x 32767 is huge.

-- 
Dave Page
Blog: https://pgsnake.blogspot.com
Twitter: @pgsnake

EDB: https://www.enterprisedb.com

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 7 Apr 2022 10:15:35 +0530

Hi Dave/Hackers,

Attached is the updated patch to change the message.

> Can we similarly limit the size of the design canvas? 32767 x 32767 is
There are just too many tables to fit in. I tried to create an SVG image
instead of PNG and it went 200MB.
I will see if we can limit the size of canvas as well.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 7 Apr 2022 15:20:16 +0530

Thanks, the patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*