Subject: [pgAdmin][RM6207] Update JS dependencies

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 8 Feb 2021 17:07:05 +0530

Hi Hackers,

Attached is the patch to update the JS dependencies to latest. Changes
include:
1) Migrate from webpack 4 to webpack 5. This had a lot of breaking changes,
so updated multiple webpack plugins and changed the config accordingly.
2) Replaced iconfont-webpack-plugin with a more maintained  webfonts-loader.
3)  Replaced deprecated babel-eslint with @babel/eslint-parser
4)  Replaced optimize-css-assets-webpack-plugin with a more maintained
css-minimizer-webpack-plugin
5) Updated all other JS packages and made the required code changes.

Note, there is an update available for slickgrid and I tried to update it.
But it was not working as expected. So without wasting time, I've not
updated slickgrid, and can be updated as a separate task.

Please review.

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 9 Feb 2021 16:34:56 +0530

Hi Aditya

One jasmine test is failing, please fix that and resend the patch.

On Mon, Feb 8, 2021 at 5:07 PM Aditya Toshniwal <
[email-masked]> wrote:

> 1) Migrate from webpack 4 to webpack 5. This had a lot of breaking
> changes, so updated multiple webpack plugins and changed the config
> accordingly.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 10 Feb 2021 12:07:33 +0530

Hi,

> One jasmine test is failing, please fix that and resend the patch.
It was failing because of a side effect of some other test case. Fixed.

Please review.

>> Note, there is an update available for slickgrid and I tried to update
>> it. But it was not working as expected. So without wasting time, I've not

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 10 Feb 2021 12:50:59 +0530

Thanks, patch applied.

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 10 Feb 2021 13:36:56 +0530

Hi,

The imagemin-gifsicle package is used to compress gif images. The latest
version of imagemin-gifsicle requires the binaries to be built from source,
which has a big dependency of dh-autoreconf.
pgAdmin has very few gifs. Instead of installing dh-autoreconf, I've
removed imagemin-gifsicle from package.json since the cost of installing
dh-autoreconf is more than the output of compressing gif.
Attached is the patch.

On Wed, Feb 10, 2021 at 12:51 PM Akshay Joshi <[email-masked]>
wrote:

>> On Tue, Feb 9, 2021 at 4:35 PM Akshay Joshi <
>> [email-masked]> wrote:
>>
>>> Hi Aditya
>>>

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 10 Feb 2021 13:47:44 +0530

Thanks, patch applied.

On Wed, Feb 10, 2021 at 1:37 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Wed, Feb 10, 2021 at 12:51 PM Akshay Joshi <

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 10 Feb 2021 16:37:01 +0530

Hi,

The preview images for the themes are not visible after this. Please find
the attached patch to fix.

On Wed, Feb 10, 2021 at 1:47 PM Akshay Joshi <[email-masked]>
wrote:

>>>>>> Attached is the patch to update the JS dependencies to latest.
>>>>>> Changes include:
>>>>>> 4)  Replaced optimize-css-assets-webpack-plugin with a more
>>>>>> maintained css-minimizer-webpack-plugin
>>>>>> Note, there is an update available for slickgrid and I tried to
>>>>>> update it. But it was not working as expected. So without wasting time,
>>>>>> I've not updated slickgrid, and can be updated as a separate task.
>>>>>>
>>>>>> Please review.
>>>>>>
>>>>>> --
>>>>>> Thanks,
>>>>>> Aditya Toshniwal

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 10 Feb 2021 17:41:58 +0530

Thanks, patch applied.

On Wed, Feb 10, 2021 at 4:37 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Wed, Feb 10, 2021 at 1:47 PM Akshay Joshi <