Subject: [pgAdmin4][RM3903] Query Tool Initialization Error

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 28 Jan 2019 14:32:07 +0530

Hi Hackers,

Attached is the patch to fix "Query Tool Initialization Error" which occurs
on opening query tool for some users.
The problem was, request data was sent from client but was not read by back
end service. In flask, if you receive POST data in a request you *must* read
it before returning a response.
Also removed a dead code, which was not referred/used anywhere.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB Software Solutions | Pune
"Don't Complain about Heat, Plant a tree"

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 29 Jan 2019 11:46:06 +0530

Thanks patch applied.

On Mon, Jan 28, 2019 at 2:32 PM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Hackers,
>
> Attached is the patch to fix "Query Tool Initialization Error" which
> occurs on opening query tool for some users.
> The problem was, request data was sent from client but was not read by
> back end service. In flask, if you receive POST data in a request you
> *must* read it before returning a response.

-- 
*Akshay Joshi*

*Sr. Software Architect *

*Phone: +91 20-3058-9517Mobile: +91 976-788-8246*