Subject: [pgAdmin][RM5794] Excessive CPU usage while browser is idle

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 7 Sep 2020 15:59:02 +0530

Hi Hackers,

Attached is the patch to stop the indefinite growth of graph dataset. This
has caused excessive CPU usage and the patch will reduce it.

Please review.

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 7 Sep 2020 18:48:47 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 9 Sep 2020 11:39:15 +0530

Hi,

In the previous patch, I had changed the react state directly, which is not
recommended and can cause unpredictable behavior.
Attached patch changes the previous commit to avoid changing state directly.

Please review.

On Mon, Sep 7, 2020 at 6:48 PM Akshay Joshi <[email-masked]>
wrote:

>> Attached is the patch to stop the indefinite growth of graph dataset.
>> This has caused excessive CPU usage and the patch will reduce it.
>>
>> Please review.
>>
>> --
>> Thanks,
>> Aditya Toshniwal