Subject: Red Hat 7.9 FIPS 140-2 issue pgAdmin 4.27

From: "Watson, Karen L [US] (MS)" <[email-masked]>
Date: Fri, 18 Dec 2020 19:15:44 +0000

If this is the wrong list please direct me to where I need to post this question.

I'm working for a customer that requires fips 140-2 be turned on at the operating system level.  The server is Red Hat 7.9 and is using python 3.6.8.
I'm trying to install pgAdmin 4.27 in server mode.

When running setup.py after being prompted for the email address and password for the initial pgAdmin user I get an error message EVP_DigestInit_ex:disabled for fips.  I can provide a more detailed message when I'm onsite next week at the customer site if needed.

I have searched the lists and the internet but have not found much information.  A few posts where individuals were having a problem but no answers if pgAdmin will work on a fips 140-2 linux system.

We had attempted to install pgAdmin a year ago on a fips 140-2 enabled Red Hat OS and found out pgAdmin uses md5 and would not work when logging in via the web login.  We were hoping this had been fixed since there are customers that require the enablement of fips 140-2 on their servers.

1)      So can someone tell me if pgAdmin will work on a Red Hat 7 server when the operating system is in fips 140-2?  Yes/No

2)      If no, is there somewhere in the python code for pgAdmin we can update to get pgAdmin to work when the operating system is in fips 140-2?  Yes/No

3)      If the answers to the above two questions are "No" does anyone have any recommendations for client software that developers can use from Window PCs to access the postgres database?

Thank you in advance for any help with this.

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 21 Dec 2020 12:21:21 +0530

Hi Karen,

pgAdmin is not tested in fips 140-2. No one reported such an issue, so we
were not aware of it.
You can log the feature request here -
https://redmine.postgresql.org/projects/pgadmin4/issues/new so that we can
discuss and work on it.

On Sat, Dec 19, 2020 at 12:46 AM Watson, Karen L [US] (MS) <
[email-masked]> wrote:

> I’m working for a customer that requires fips 140-2 be turned on at the
> operating system level.  The server is Red Hat 7.9 and is using python
> 3.6.8.
>
> I’m trying to install pgAdmin 4.27 in server mode.
>
>
>
> When running setup.py after being prompted for the email address and
> password for the initial pgAdmin user I get an error message
> EVP_DigestInit_ex:disabled for fips.  I can provide a more detailed message
> when I’m onsite next week at the customer site if needed.
>
>
>
> I have searched the lists and the internet but have not found much
> information.  A few posts where individuals were having a problem but no
> answers if pgAdmin will work on a fips 140-2 linux system.
>
>
>
> We had attempted to install pgAdmin a year ago on a fips 140-2 enabled Red
> Hat OS and found out pgAdmin uses md5 and would not work when logging in
> via the web login.  We were hoping this had been fixed since there are
> customers that require the enablement of fips 140-2 on their servers.
>
>
>
> 1)      So can someone tell me if pgAdmin will work on a Red Hat 7 server
> when the operating system is in fips 140-2?  Yes/No
>
> 2)      If no, is there somewhere in the python code for pgAdmin we can
> update to get pgAdmin to work when the operating system is in fips 140-2?
> Yes/No
>
> 3)      If the answers to the above two questions are “No” does anyone
> have any recommendations for client software that developers can use from
> Window PCs to access the postgres database?
>
>
>

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: "Watson, Karen L [US] (MS)" <[email-masked]>
Date: Mon, 21 Dec 2020 14:09:25 +0000

Thank you, I’ve opened a feature request #6104.

From: Aditya Toshniwal [mailto:[email-masked]]
Sent: Monday, December 21, 2020 1:51 AM
To: Watson, Karen L [US] (MS) <[email-masked]>
Cc: [email-masked]
Subject: EXT :Re: Red Hat 7.9 FIPS 140-2 issue pgAdmin 4.27

Hi Karen,

pgAdmin is not tested in fips 140-2. No one reported such an issue, so we were not aware of it.
You can log the feature request here - https://redmine.postgresql.org/projects/pgadmin4/issues/new so that we can discuss and work on it.

On Sat, Dec 19, 2020 at 12:46 AM Watson, Karen L [US] (MS) <[email-masked]<mailto:[email-masked]>> wrote:
If this is the wrong list please direct me to where I need to post this question.

I’m working for a customer that requires fips 140-2 be turned on at the operating system level.  The server is Red Hat 7.9 and is using python 3.6.8.
I’m trying to install pgAdmin 4.27 in server mode.

When running setup.py after being prompted for the email address and password for the initial pgAdmin user I get an error message EVP_DigestInit_ex:disabled for fips.  I can provide a more detailed message when I’m onsite next week at the customer site if needed.

3)      If the answers to the above two questions are “No” does anyone have any recommendations for client software that developers can use from Window PCs to access the postgres database?

--
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | edbpostgres.com<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"