Subject: [pgAdmin][RM4988] Refactoring of all the SQL files used by pgAdmin4

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 16 Dec 2019 17:39:37 +0530

Hi Hackers,

Attached patch which is related to RM4988, reduces the number of hits
to edit_mode_types.sql
(an expensive one).
Currently, this is query is executed for every column one by one when table
properties dialog is opened. I've added edit_mode_types_bulk.sql, which
will fetch the edit types for all the distinct column types used in the
table in a single DB trip and use that data for each column.
Also, while generating RE-SQL for columns, edit_mode_types.sql will not be
executed.
This will definitely reduce time.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 16 Dec 2019 18:54:36 +0530

Thanks, patch applied.

On Mon, Dec 16, 2019 at 5:40 PM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Hackers,
>
> Attached patch which is related to RM4988, reduces the number of hits to edit_mode_types.sql
> (an expensive one).
> Currently, this is query is executed for every column one by one when
> table properties dialog is opened. I've added edit_mode_types_bulk.sql,
> which will fetch the edit types for all the distinct column types used in
> the table in a single DB trip and use that data for each column.
> Also, while generating RE-SQL for columns, edit_mode_types.sql will not
> be executed.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 18 Dec 2019 13:12:04 +0530

Hi Hackers,

Had couple of typos in the previous patch. Although the edit types were
passed to the front end, they were not filtered and all the types were
displayed in edit table dialog.
Kindly find the patch to fix it.

-- 
Thanks and Regards,
Aditya Toshniwal
pgAdmin Hacker | Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 18 Dec 2019 13:36:39 +0530

Thanks, patch applied.

On Wed, Dec 18, 2019 at 1:12 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Mon, Dec 16, 2019 at 6:54 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Thanks, patch applied.
>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*