Subject: pgAdmin4 v8.13 candidate builds

From: Akshay Joshi <[email-masked]>
Date: Mon, 14 Oct 2024 17:14:53 +0530

Hi All,

pgAdmin4 v8.13 candidate builds and source code is available at
https://developer.pgadmin.org/builds/2024-10-14-1/

Yogesh, could you please verify this for Thursday's release?

Akshay Joshi

Principle Software Architect

enterprisedb.com

*  Blog*: https://www.enterprisedb.com/akshay-joshi
*  GitHub*: https://github.com/akshay-joshi
*  LinkedIn*: https://www.linkedin.com/in/akshay-joshi-086497216

---

From: Usman Khan <[email-masked]>
Date: Mon, 14 Oct 2024 18:10:54 +0500

Hi,
I would verify the build on windows 11 and ubuntu 24.04. Will try to
complete it by EOD tomorrow.

---

From: Usman Khan <[email-masked]>
Date: Tue, 15 Oct 2024 16:59:48 +0500

Hi Akshay/Hackers,
The release verification for following platforms is done
1. Ubuntu 24.04
2. windows 11

Both fresh installation and upgrade scenarios are performed with basic
sanity testing.

On Mon, Oct 14, 2024 at 6:10 PM Usman Khan <[email-masked]> wrote:

> On Mon, Oct 14, 2024 at 4:45 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi All,
>>

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 15 Oct 2024 17:40:14 +0530

Hi All

We have found one issue on Windows where the Digital Signature is missing.
We have fixed it.

The latest candidate builds and source code is available at
https://developer.pgadmin.org/builds/2024-10-15-1/

---

From: Usman Khan <[email-masked]>
Date: Wed, 16 Oct 2024 11:53:41 +0500

Hi Akshay,
Any bug reported for this issue for reference?
I would be able to revery after 5:00PM PST.

On Tue, Oct 15, 2024 at 5:10 PM Akshay Joshi <[email-masked]>
wrote:

> On Mon, Oct 14, 2024 at 5:14 PM Akshay Joshi <

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 16 Oct 2024 14:54:22 +0530

> I would be able to revery after 5:00PM PST.

    The bug is not reported for this. This is the first step we generally
test after downloading the installer.

>
> On Tue, Oct 15, 2024 at 5:10 PM Akshay Joshi <
>> We have found one issue on Windows where the Digital Signature is
>> missing. We have fixed it.
>>

---

From: Usman Khan <[email-masked]>
Date: Wed, 16 Oct 2024 16:54:39 +0500

On Wed, Oct 16, 2024 at 2:24 PM Akshay Joshi <[email-masked]>
wrote:

>     The bug is not reported for this.
>

> This is the first step we generally test after downloading the installe.
>
Make sense. Are there any written steps/process for verifying release
builds on different platforms?

---

From: Usman Khan <[email-masked]>
Date: Wed, 16 Oct 2024 18:53:03 +0500

Verified, the issue related to digital signature is fixed.

I have encountered the following error while restoring a very simple
database .

I tried with 8.12 with the same steps and it was successful.

---

From: Ashesh Vashi <[email-masked]>
Date: Wed, 16 Oct 2024 21:12:42 +0530

Please mentioned the database server version, and probably the steps to
reproduction.

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>

---

From: Usman Khan <[email-masked]>
Date: Wed, 16 Oct 2024 23:27:30 +0500

Sorry it was my bad, I forgot to mention details.

The detail is as following
*Server *: "PostgreSQL 16.4, compiled by Visual C++ build 1940, 64-bit"
*STEPS:*
1. Create a new database 'test1'
2. Create a new schema 'testscheme' in 'test1' and create a single table
with a single column type integer.
3. Create a backup with default values through pgadmin4 context menu
4. Create another database 'test2'
5.Restore the backup created at step 3. above through the context menu of
the tree with default values on the dialogue.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 17 Oct 2024 12:27:33 +0530

Hi All,

We encountered an issue during the installation of pgAdmin 4 on Fedora when
any version of PostgreSQL is already installed. We are getting below error:

Error: Transaction test error: file /usr/share/pgsql/postgres.bki from
install of libpq5-17.0-42PGDG.f39.x86_64 conflicts with file from package
postgresql-server-15.6-1.fc39.x86_64 file
/usr/share/pgsql/system_constraints.sql from install of
libpq5-17.0-42PGDG.f39.x86_64 conflicts with file from package
postgresql-server-15.6-1.fc39.x86_64

We are trying to fix the above error. We will have to reschedule the
release until this issue is resolved. If it will resolve today then we will
release pgAdmin tomorrow.

On Wed, Oct 16, 2024 at 11:57 PM Usman Khan <[email-masked]> wrote:

> On Wed, Oct 16, 2024 at 8:42 PM Ashesh Vashi <
> [email-masked]> wrote:
>

---

From: Dave Page <[email-masked]>
Date: Thu, 17 Oct 2024 08:06:09 +0100

Devrim, can you assist with this please?

On Thu, 17 Oct 2024 at 07:57, Akshay Joshi <[email-masked]>
wrote:

> Hi All,
>
> We encountered an issue during the installation of pgAdmin 4 on Fedora
> when any version of PostgreSQL is already installed. We are getting
> below error:
>

---

From: Usman Khan <[email-masked]>
Date: Thu, 17 Oct 2024 12:06:57 +0500

Hi Akshay,
Is the above issue regarding backup/restore also being worked out? I have
also reported it as following
https://github.com/pgadmin-org/pgadmin4/issues/8044
and provided all the details.

---

From: Devrim Gunduz <[email-masked]>
Date: Thu, 17 Oct 2024 10:54:39 +0300

Hi,

This is similar to:

https://www.postgresql.org/message-id/bba7d2dd6f4aa8d9725d89b1a691c1e4e220902d.camel%40cybertec.at

I can take out .bki and that .sql file from the package, but this will be
opposite of what I am working on nowadays.

I will let you know when I publish the new libpq5 package.

On Thu, 17 Oct 2024, 10:06 Dave Page, <[email-masked]> wrote:

>>> 5.Restore the backup created at step 3. above through the context menu
>>> of the tree with default values on the dialogue.
>>>
>>>

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 17 Oct 2024 13:56:08 +0530

> I will let you know when I publish the new libpq5 package.

    Thanks Devrim

>>>> 2. Create a new schema 'testscheme' in 'test1' and create a single
>>>> table with a single column type integer.
>>>>> Please mentioned the database server version, and probably the steps
>>>>> to reproduction.
>>>>>
>>>>> --
>>>>>
>>>>> Thanks & Regards,
>>>>>
>>>>> Ashesh Vashi

---

From: Dave Page <[email-masked]>
Date: Thu, 17 Oct 2024 09:37:43 +0100

Thanks. I don’t understand why we’d ship bki files with libpq though?

-- 
Dave Page
https://pgsnake.blogspot.com

EDB Postgres
https://www.enterprisedb.com

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 17 Oct 2024 13:41:43 +0300

Should be fixed in 17.0-43 package.

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 17 Oct 2024 13:42:19 +0300

make install installs them, and I did not care at that point

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 17 Oct 2024 16:13:41 +0530

Hi Devrim

When should I start the pgAdmin 4 build?

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 17 Oct 2024 14:56:05 +0300

Hi,

They are already in the repos.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 17 Oct 2024 18:30:20 +0530

The latest candidate builds and source code is available at
https://developer.pgadmin.org/builds/2024-10-17-1/

On Thu, Oct 17, 2024 at 5:26 PM Devrim Gündüz <[email-masked]> wrote:

>>>> On Thu, 17 Oct 2024 at 07:57, Akshay Joshi <
>>>>>> 5.Restore the backup created at step 3. above through the context
>>>>>> menu of the tree with default values on the dialogue.
>>>>>>
>>>>>>
>>>>>>>> I have encountered the following error while restoring a very
>>>>>>>> simple database .
>>>>>>>>
>>>>>>>>

---

From: Yogesh Mahajan <[email-masked]>
Date: Mon, 21 Oct 2024 09:21:17 +0530

Hi All

We have found one issue on Ubuntu 20.04 with python 3.8 and MFA
authentication registration failure. We have fixed it.

The latest candidate builds and source code is available at
https://developer.pgadmin.org/builds/2024-10-19-2/

Thanks,
Yogesh Mahajan
EnterpriseDB

On Thu, Oct 17, 2024 at 6:30 PM Akshay Joshi <[email-masked]>
wrote:

>>>>>> We encountered an issue during the installation of pgAdmin 4 on
>>>>>> Fedora when any version of PostgreSQL is already installed. We are getting
>>>>>> below error:
>>>>>>
>>>>>> Error: Transaction test error: file /usr/share/pgsql/postgres.bki
>>>>>> from install of libpq5-17.0-42PGDG.f39.x86_64 conflicts with file from
>>>>>> package postgresql-server-15.6-1.fc39.x86_64 file
>>>>>>>> Please mentioned the database server version, and probably the
>>>>>>>> steps to reproduction.
>>>>>>>>
>>>>>>>> --
>>>>>>>>
>>>>>>>> Thanks & Regards,
>>>>>>>>
>>>>>>>> Ashesh Vashi

---

From: Usman Khan <[email-masked]>
Date: Mon, 21 Oct 2024 11:01:09 +0500

Hi Hackers,
I would be able to do the verification after 5pm PST, if it's urgent,
please someone take care of following platforms
1. windows 11
2. ubuntu 24.04

On Mon, Oct 21, 2024 at 8:52 AM Yogesh Mahajan <
[email-masked]> wrote:

> On Thu, Oct 17, 2024 at 6:30 PM Akshay Joshi <
>>>>>>>>>>> We have found one issue on Windows where the Digital Signature
>>>>>>>>>>> is missing. We have fixed it.
>>>>>>>>>>>
>>>>>>>>>>>> *  LinkedIn*:
>>>>>>>>>>>> https://www.linkedin.com/in/akshay-joshi-086497216
>>>>>>>>>>>>
>>>>>>>>>>>

---

From: Usman Khan <[email-masked]>
Date: Mon, 21 Oct 2024 18:14:08 +0500

Hi Hackers,

I performed the basic sanity for the installers for following

   -  ubuntu 24.04
   -  windows 11

No issue found at my end. For reference I have performed basic sanity with
attached test cases.

On Mon, Oct 21, 2024 at 11:01 AM Usman Khan <[email-masked]> wrote:

>>>>>>>> We are trying to fix the above error. We will have to reschedule
>>>>>>>> the release until this issue is resolved. If it will resolve today then we
>>>>>>>> will release pgAdmin tomorrow.
>>>>>>>>
>>>>>>>>>>>>> pgAdmin4 v8.13 candidate builds and source code is available
>>>>>>>>>>>>> at https://developer.pgadmin.org/builds/2024-10-14-1/
>>>>>>>>>>>>>