Subject: Feature Tests failures

From: Usman Khan <[email-masked]>
Date: Mon, 29 Apr 2024 14:32:42 +0500

Hi Team,
I am Usman Muzaffar, I in the past worked on feature tests. Recently, I
tried to execute feature tests without selenoid, but was stuck with the
following error for all the test cases.

=======
Browser tool bar feature test ... skipped "Currently, config is set to
start pgadmin in server mode. This test doesn't know username and password
so doesn't work in server mode"
=======

I used the following command to execute the test cases
*python3 runtests.py --pkg=feature_tests*

The complete logs are also attached here. For your reference, config file
is also attached

Regards,
Usman Muzaffar

---

From: Yogesh Mahajan <[email-masked]>
Date: Tue, 7 May 2024 10:01:38 +0530

Hi,

Please set SERVER_MODE=False in config_local.py and try again.

Thanks,
Yogesh Mahajan
EnterpriseDB

---

From: Usman Khan <[email-masked]>
Date: Fri, 10 May 2024 15:11:27 +0500

Hi,
Thanks, that worked.
But currently I am running the cases, the spinner keeps rotating and scope
does not get past this point.

---

From: Yogesh Mahajan <[email-masked]>
Date: Tue, 14 May 2024 10:18:15 +0530

Hi,

Can you please share your config_local.py and test_config.json? Also which
browser are you using?

Thanks,
Yogesh Mahajan
EnterpriseDB

On Fri, May 10, 2024 at 3:41 PM Usman Khan <[email-masked]> wrote:

>>> The complete logs are also attached here. For your reference, config
>>> file is also attached
>>>
>>> Regards,
>>> Usman Muzaffar
>>>
>>

---

From: Usman Khan <[email-masked]>
Date: Tue, 14 May 2024 12:40:29 +0500

Hi,

Please find here the attached files, it contains following
i) config.py/config_local.py
ii) test_config.json
iii) screenshots

*Other Info*

   - I am on master branch with today's latest code
   - I am using following
   - ubuntu 22
      - chrome version 124

On Tue, May 14, 2024 at 9:48 AM Yogesh Mahajan <
[email-masked]> wrote:

>> But currently I am running the cases, the spinner keeps rotating and
>> scope does not get past this point.
>>
>>

---

From: Usman Khan <[email-masked]>
Date: Sun, 19 May 2024 15:51:40 +0500

Hi,
Any update on this?

On Tue, May 14, 2024 at 12:40 PM Usman Khan <[email-masked]> wrote:

>> Can you please share your config_local.py and test_config.json? Also
>> which browser are you using?
>>
>> Thanks,
>> Yogesh Mahajan
>> EnterpriseDB
>>
>>
>>>>> I am Usman Muzaffar, I in the past worked on feature tests. Recently,
>>>>> I tried to execute feature tests without selenoid, but was stuck with the

---

From: Yogesh Mahajan <[email-masked]>
Date: Mon, 20 May 2024 15:55:41 +0530

Hi,

I guess you have forgotten to attach the files.

Thanks,
Yogesh Mahajan
EnterpriseDB

On Sun, May 19, 2024 at 4:21 PM Usman Khan <[email-masked]> wrote:

>>>>>> Browser tool bar feature test ... skipped "Currently, config is set
>>>>>> to start pgadmin in server mode. This test doesn't know username and
>>>>>> password so doesn't work in server mode"
>>>>>> =======
>>>>>>

---

From: Usman Khan <[email-masked]>
Date: Mon, 20 May 2024 15:53:56 +0500

Hi,

Please find the attached files again.

On Mon, May 20, 2024 at 3:26 PM Yogesh Mahajan <
[email-masked]> wrote:

>>>>>>> I am Usman Muzaffar, I in the past worked on feature tests.
>>>>>>> Recently, I tried to execute feature tests without selenoid, but was stuck
>>>>>>> with the following error for all the test cases.
>>>>>>>
>>>>>>> =======

---

From: Usman Khan <[email-masked]>
Date: Mon, 20 May 2024 19:39:37 +0500

Hi,
Kindly confirm if the attachments are received this time? As for the last
two emails I attached them in zip format which is also present in my sent
box.

On Mon, May 20, 2024 at 3:53 PM Usman Khan <[email-masked]> wrote:

>>>>>>>> The complete logs are also attached here. For your reference,
>>>>>>>> config file is also attached
>>>>>>>>
>>>>>>>> Regards,
>>>>>>>> Usman Muzaffar
>>>>>>>>
>>>>>>>

---

From: Yogesh Mahajan <[email-masked]>
Date: Tue, 21 May 2024 11:41:51 +0530

Hi,

Still the email did not show any attachments. See the screenshot for email.
File attachment sign is missing on the right side which means no files are
attached in the email.

Thanks,
Yogesh Mahajan
EnterpriseDB

On Mon, May 20, 2024 at 8:09 PM Usman Khan <[email-masked]> wrote:

>>>>>>>>> Browser tool bar feature test ... skipped "Currently, config is
>>>>>>>>> set to start pgadmin in server mode. This test doesn't know username and

---

From: Usman Khan <[email-masked]>
Date: Tue, 21 May 2024 11:53:19 +0500

Hi,
Sorry about that, I do not know what is wrong as  attachments are present
with previous emails every time.
Let me this time send it again without zip format and screenshots(as
previously the size was about 1.4mb).

On Tue, May 21, 2024 at 11:12 AM Yogesh Mahajan <
[email-masked]> wrote:

> Hi,
>
> Still the email did not show any attachments. See the screenshot for
> email. File attachment sign is missing on the right side which means no
> files are attached in the email.
>
>
> Thanks,
> Yogesh Mahajan
> EnterpriseDB
>
>
>>>>>>>> But currently I am running the cases, the spinner keeps rotating
>>>>>>>> and scope does not get past this point.
>>>>>>>>
>>>>>>>>