Subject: [pgAdmin][Patch] RM 6082 - Able to change connection when a long query is running

From: Yogesh Mahajan <[email-masked]>
Date: Tue, 6 Apr 2021 13:42:24 +0530

Hello,

Please find a patch which diables change of connection from query tool
while query tool transaction is in progress.

Thanks,
Yogesh Mahajan
EnterpriseDB

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 6 Apr 2021 16:07:17 +0530

Hi Yogesh

The issue is not fixed yet. I am able to change the connection while the
transaction is in progress. Please check and resend the patch.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Yogesh Mahajan <[email-masked]>
Date: Wed, 7 Apr 2021 13:40:16 +0530

Hello,

Sorry for the inconvenience.
Please update the patch.

Thanks,
Yogesh Mahajan
EnterpriseDB

---

From: Yogesh Mahajan <[email-masked]>
Date: Thu, 8 Apr 2021 16:14:30 +0530

Hi,

Please discard the previous patch.
Here is the latest patch. This also fixes the issue of disappearing the
connection bar from the query tool on the resize pgAdmin window.

Thanks,
Yogesh Mahajan
EnterpriseDB

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 8 Apr 2021 18:16:15 +0530

Thanks, patch applied.

On Thu, Apr 8, 2021 at 4:15 PM Yogesh Mahajan <
[email-masked]> wrote:

>> On Tue, Apr 6, 2021 at 4:07 PM Akshay Joshi <
>> [email-masked]> wrote:
>>
>>> Hi Yogesh
>>>