Subject: pgadmin4 RPMs need some testing!

From: Devrim Gündüz <[email-masked]>
Date: Wed, 14 Sep 2016 12:37:32 +0300

Hi,

I pushed pgadmin4 1.0 rc1 RPMs for RHEL 7 and Fedora 23 & 24 to PostgreSQL YUM
repository:

http://yum.postgresql.org

It is currently only in 9.6 repository. Any tests are really appreciated,
before pushing it to other branches. I added about 30 new packages to
repository to satisfy dependncies. Feel free to report the issues pgadmin-
[email-masked], or to [email-masked] (preferred) lists.

RHEL 6 support is currently missing due to some missing dependencies, but I'll
work on it.

Thanks!

Regards,
-- 
Devrim GÜNDÜZ
EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Patrick Headley <[email-masked]>
Date: Wed, 14 Sep 2016 10:52:41 -0600

If someone could do a push to the openSuSE Leap repository (or packman) 
and let me know which repository to use I would be happy to test.

*/Patrick Headley/*
Linx Consulting, Inc.
[email-masked]
(303) 916-5522
www.linxco-inc.com

---

From: Jeff Janes <[email-masked]>
Date: Wed, 14 Sep 2016 11:11:35 -0700

> [email-masked], or to [email-masked] (preferred)

After installing a fresh OS from CentOS-7.0-1406-x86_64-DVD.iso and then
doing an yum update, and then installing the repository
rpm pgdg-centos96-9.6-1.noarch.rpm, and then running "sudo yum install
pgadmin4", it ends up with:

--> Finished Dependency Resolution
Error: Package: pgadmin4-web-1.0-rc1_6.rhel7.noarch (pgdg96)
           Requires: python-html5lib >= 1.0b3
Error: Package: pgadmin4-web-1.0-rc1_6.rhel7.noarch (pgdg96)
           Requires: python-speaklater >= 1.3
Error: Package: python-fixtures-3.0.0-3.rhel7.noarch (pgdg96)
           Requires: python-testtools >= 0.9.22
Error: Package: python-flask-babel-0.11.1-1.rhel7.noarch (pgdg96)
           Requires: python-speaklater
Error: Package: pgadmin4-web-1.0-rc1_6.rhel7.noarch (pgdg96)
           Requires: python-extras >= 0.0.3
Error: Package: pgadmin4-web-1.0-rc1_6.rhel7.noarch (pgdg96)
           Requires: python-passlib >= 1.6.2
Error: Package: pgadmin4-web-1.0-rc1_6.rhel7.noarch (pgdg96)
           Requires: python-click
Error: Package: pgadmin4-1.0-rc1_6.rhel7.x86_64 (pgdg96)
           Requires: libQtWebKit.so.4()(64bit)

Once I installed the epel repository (yum -y install epel-release) on a
hunch, it then installed successfully.

Is it possible to mark a package as depending on a different repository, or
is that not the way it works?

Cheers,

Jeff

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 14 Sep 2016 21:42:00 +0300

Hi Jeff,

> hunch, it then installed successfully.

Great, thanks!

> is that not the way it works?

PGDG repository already depends on EPEL at least for pgadmin3 and postgis (and
some more packages). 

Just updated

http://yum.postgresql.org/repopackages.php

with a bold sentence. I don't know a way to specify dependency against an
external repo. 

Regards,

---

From: Jeff Janes <[email-masked]>
Date: Wed, 14 Sep 2016 12:32:56 -0700

> with a bold sentence. I don't know a way to specify dependency against an

Thanks, I think that that note will be helpful.

Jeff

---

From: Olav Peeters <[email-masked]>
Date: Wed, 5 Oct 2016 05:37:47 -0700 (MST)

Hi,
I posted an issue related to installing pgadmin4 on CentOS 7 via yum this
morning (see:
http://postgresql.nabble.com/pgAdmin4-as-web-application-on-CentOS-td5924512.html).
Can you have a look at it? I'll gladly help with testing.
Cheers,
Olav

--
View this message in context: http://postgresql.nabble.com/pgadmin4-RPMs-need-some-testing-tp5921120p5924544.html
Sent from the PostgreSQL - pgadmin hackers mailing list archive at Nabble.com.

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers