Subject: [pgAdmin][RM5048] : code coverage tool

From: navnath gadakh <[email-masked]>
Date: Fri, 3 Jan 2020 13:30:16 +0530

Hi Team,
      Please find the attached patch to calculate code coverage if pgadmin
code(python tests).
I have extended the existing testsuite to enable coverage. I have used
python's coverage module.

*Some useful commands: *

before running the commands make sure you create .coveragerc file under
/regression directory(details mentioned in README)
Run coverage

    With all modules
        run 'python runtests.py --coverage --exclude feature_tests'
    With specific module
        run 'python runtests.py --pkg
browser.server_groups.servers.tests --coverage'

Thanks!
-- 
*Regards,*
*Navnath Gadakh*

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 3 Jan 2020 19:01:27 +0530

Thanks, patch applied.

On Fri, Jan 3, 2020 at 1:38 PM navnath gadakh <[email-masked]>
wrote:

>         run 'python runtests.py --pkg browser.server_groups.servers.tests --coverage'
>
> Thanks!
> --
> *Regards,*
> *Navnath Gadakh*
>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*