Subject: pgAdmin4 v8.10 candidate builds

From: Akshay Joshi <[email-masked]>
Date: Tue, 23 Jul 2024 18:02:33 +0530

Hi All,

pgAdmin4 v8.10 candidate builds and source code is available at
https://developer.pgadmin.org/builds/2024-07-23-1/

Yogesh, could you please verify this for Thursday's release?

*Note:-  We have transitioned from NW.js to Electron starting with this
release.*

Akshay Joshi

Principle Software Architect

enterprisedb.com

*  Blog*: https://www.enterprisedb.com/akshay-joshi
*  GitHub*: https://github.com/akshay-joshi
*  LinkedIn*: https://www.linkedin.com/in/akshay-joshi-086497216

---

From: Usman Khan <[email-masked]>
Date: Wed, 24 Jul 2024 10:28:45 +0500

Hi Hackers,
I will verify the build on ubuntu 24.04 and windows 11.

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 24 Jul 2024 16:59:07 +0530

The new candidate builds and source code is available at
https://developer.pgadmin.org/builds/2024-07-24-1/

On Wed, Jul 24, 2024 at 10:58 AM Usman Khan <[email-masked]> wrote:

> On Tue, Jul 23, 2024 at 5:32 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi All,
>>

---

From: Usman Khan <[email-masked]>
Date: Wed, 24 Jul 2024 16:49:44 +0500

I am not able to launch desktop pgadmin on ubuntu 24.04. Getting following
error

Web pgadmin4 working fine.

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 24 Jul 2024 17:29:56 +0530

Hi Usman,

pgAdmin doesn't support ARM Linux yet. ARM is supported only for Mac.

-- 
Thanks,
Aditya Toshniwal
pgAdmin Hacker | Sr. Software Architect | *enterprisedb.com*
<https://www.enterprisedb.com/>
"Don't Complain about Heat, Plant a TREE"

---

From: Usman Khan <[email-masked]>
Date: Wed, 24 Jul 2024 17:07:19 +0500

I am on following linux platform with architecture
----------------------------------------------------------------------------------------------------
root@ubuntu-VirtualBox:/home/ubuntu/Desktop# uname -m
x86_64
root@ubuntu-VirtualBox:/home/ubuntu/Desktop# cat /etc/os-release
PRETTY_NAME="Ubuntu 24.04 LTS"
NAME="Ubuntu"
VERSION_ID="24.04"
VERSION="24.04 LTS (Noble Numbat)"
VERSION_CODENAME=noble
ID=ubuntu
ID_LIKE=debian
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="
https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
UBUNTU_CODENAME=noble
LOGO=ubuntu-logo
root@ubuntu-VirtualBox:/home/ubuntu/Desktop#
-----------------------------------------------------------------------------------------------------------------------------------

On Wed, Jul 24, 2024 at 5:00 PM Aditya Toshniwal <
[email-masked]> wrote:

>> I am not able to launch desktop pgadmin on ubuntu 24.04. Getting
>> following error
>>

---

From: Zaid Shabbir <[email-masked]>
Date: Wed, 24 Jul 2024 17:08:30 +0500

Hello Aditya,

Can you please list down all the platform versions where pgAdmin4 v8.10
supported. List helpful to understand where it should work.

Thanks & Regards
Zaid

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 24 Jul 2024 17:42:25 +0530

Hi Zaid,

You can check the pgAdmin website https://www.pgadmin.org/download/ and go
to the platform to check the list.

On Wed, Jul 24, 2024 at 5:38 PM Zaid Shabbir <[email-masked]> wrote:

>>>>> *Note:-  We have transitioned from NW.js to Electron starting with
>>>>> this release.*
>>>>>
>>>>>
>>>>> Akshay Joshi
>>>>>

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 24 Jul 2024 17:43:14 +0530

Sorry, my bad. I misread the screenshot with amd as arm. Will check once at
my end.

---

From: Zaid Shabbir <[email-masked]>
Date: Wed, 24 Jul 2024 17:23:24 +0500

Hello,

Regarding the pgAdmin4 support on different platform version its looks me
very difficult to identify the supported version

e.g.

In the above list, it is not mentioned what the last supported version of
pgAdmin 4 is for Rockey Linux 8x. In my opinion, it would be better to list
all major/minor version supports in a single place.

Thanks & Regards
Zaid Shabbir

On Wed, Jul 24, 2024 at 5:13 PM Aditya Toshniwal <
[email-masked]> wrote:

> Sorry, my bad. I misread the screenshot with amd as arm. Will check once
> at my end.
>

---

From: Dave Page <[email-masked]>
Date: Wed, 24 Jul 2024 13:26:08 +0100

Hi

> all major/minor version supports in a single place.

There isn't a last supported version for Rocky 8 yet. That means it's still
supported.

-- 
Dave Page
pgAdmin: https://www.pgadmin.org
PostgreSQL: https://www.postgresql.org
EDB: https://www.enterprisedb.com

PGDay UK 2024, 11th September, London: https://2024.pgday.uk/

---

From: Usman Khan <[email-masked]>
Date: Wed, 24 Jul 2024 17:27:53 +0500

Thanks,
Is there any pre req related to ELECTRON? Because for the previous releases
I did not face any issue.

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 24 Jul 2024 18:06:47 +0530

On Wed, Jul 24, 2024 at 5:58 PM Usman Khan <[email-masked]> wrote:

> Thanks,
> Is there any pre req related to ELECTRON? Because for the previous
> releases I did not face any issue.
>

    This is the first release with ELECTRON.

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 24 Jul 2024 18:06:54 +0530

Hi Usman,

I suspect it is related to this
https://github.com/electron/electron/issues/41066

---

From: Usman Khan <[email-masked]>
Date: Wed, 24 Jul 2024 17:44:27 +0500

Yes, it seems like. But if its so then we should mention it in the know
bugs of the release?

---

From: Dave Page <[email-masked]>
Date: Wed, 24 Jul 2024 13:45:15 +0100

> https://github.com/electron/electron/issues/41066

So we need to add something like this to our package?
https://github.com/electron/electron/issues/41066#issuecomment-2186041169

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 24 Jul 2024 18:24:34 +0530

Hi Dave,

> https://github.com/electron/electron/issues/41066#issuecomment-2186041169

I'll have to try that locally. The other solution what most people have
followed is -
https://github.com/electron/electron/issues/41066#issuecomment-1913509942

>>>> Sorry, my bad. I misread the screenshot with amd as arm. Will check
>>>> once at my end.
>>>>

---

From: Usman Khan <[email-masked]>
Date: Wed, 24 Jul 2024 19:00:53 +0500

Verification on windows 11 is done. I verified both new installation and
upgrade scenarios(from 8.9 to 8.10).
I need to reverify ubuntu 24.04 with new installers. Will update once done.

On Wed, Jul 24, 2024 at 5:55 PM Aditya Toshniwal <
[email-masked]> wrote:

>>>>>>>>>> *Note:-  We have transitioned from NW.js to Electron starting
>>>>>>>>>> with this release.*
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Akshay Joshi
>>>>>>>>>>

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 24 Jul 2024 19:31:19 +0530

Hi Dave/Usman,

I added this as mentioned in the solution and restart apparmor. pgAdmin
started working. Now I need to figure out how I can create this file when
installing pgAdmin.

---

From: Dave Page <[email-masked]>
Date: Wed, 24 Jul 2024 15:26:01 +0100

Hi

> https://github.com/electron/electron/issues/41066#issuecomment-1913509942

Sure - but that's pretty similar to avoiding selinux issues by setting
selinux to permissive mode (albeit, contained to a single protection) from
what I can see.

---

From: Usman Khan <[email-masked]>
Date: Thu, 25 Jul 2024 00:02:06 +0500

Thanks for the quick solution. Will we respin the installer after this?

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 25 Jul 2024 10:48:42 +0530

Hi Usman,

Yes, we'll need a respin. I'm adding code to post installation of the
pgAdmin deb package to place the profile.

On Thu, Jul 25, 2024 at 12:32 AM Usman Khan <[email-masked]> wrote:

>>>>>>>>>>>> *  LinkedIn*:
>>>>>>>>>>>> https://www.linkedin.com/in/akshay-joshi-086497216
>>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>
>>>>>>>>> --
>>>>>>>>> Thanks,
>>>>>>>>> Aditya Toshniwal

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 25 Jul 2024 20:06:02 +0530

Hi All

We have fixed the Ubuntu 24 crash issue. The latest candidate builds and
source code is available at
https://developer.pgadmin.org/builds/2024-07-25-1/

On Thu, Jul 25, 2024 at 10:49 AM Aditya Toshniwal <
[email-masked]> wrote:

>>>>>>>>>>>>> pgAdmin4 v8.10 candidate builds and source code is available
>>>>>>>>>>>>> at https://developer.pgadmin.org/builds/2024-07-23-1/
>>>>>>>>>>>>>

---

From: Usman Khan <[email-masked]>
Date: Fri, 26 Jul 2024 11:50:28 +0500

Thanks,
I will reverify the platforms and update.

On Thu, Jul 25, 2024 at 7:36 PM Akshay Joshi <[email-masked]>
wrote:

>>>>> I'll have to try that locally. The other solution what most people
>>>>> have followed is -
>>>>>>>>> Sorry, my bad. I misread the screenshot with amd as arm. Will
>>>>>>>>> check once at my end.
>>>>>>>>>
>>>>>>>>>>>> I am not able to launch desktop pgadmin on ubuntu 24.04.
>>>>>>>>>>>> Getting following error
>>>>>>>>>>>>

---

From: Muhammad Ikram <[email-masked]>
Date: Fri, 26 Jul 2024 12:00:37 +0500

Hello Akshay,

Do we need to test it on MacOS, if yes then I can help.

Regards,
Ikram

On Fri, Jul 26, 2024 at 11:50 AM Usman Khan <[email-masked]> wrote:

> On Thu, Jul 25, 2024 at 7:36 PM Akshay Joshi <
>>>>> I added this as mentioned in the solution and restart apparmor.
>>>>> pgAdmin started working. Now I need to figure out how I can create this
>>>>> file when installing pgAdmin.
>>>>>
>>>>>>>>>>>>>>> *Note:-  We have transitioned from NW.js to Electron
>>>>>>>>>>>>>>> starting with this release.*
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Akshay Joshi
>>>>>>>>>>>>>>>

-- 
Muhammad Ikram

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 26 Jul 2024 12:32:19 +0530

> Do we need to test it on MacOS, if yes then I can help.

   Thanks, Ikram, we have already tested it on MacOS.

>>>>>>>>>> Is there any pre req related to ELECTRON? Because for the
>>>>>>>>>> previous releases I did not face any issue.
>>>>>>>>>>

---

From: Usman Khan <[email-masked]>
Date: Fri, 26 Jul 2024 16:15:27 +0500

Hi Hackers,
I have verified the issue on ubuntu 24.04 and it's fixed. Users are able to
launch pgadmin 4 in desktop mode.

I have re verified the builds on ubuntu 24.04 and windows 11 with the
latest installer. Basic sanity is done for the following

   -  New installation with clean vm
   -  upgrade scenarios from pgadmin 4 8.9

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 26 Jul 2024 17:14:11 +0530

On Fri, Jul 26, 2024 at 4:45 PM Usman Khan <[email-masked]> wrote:

> Hi Hackers,
> I have verified the issue on ubuntu 24.04 and it's fixed. Users are able
> to launch pgadmin 4 in desktop mode.
>
   Thanks Usman

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 29 Jul 2024 10:48:43 +0530

Hi All,

We found one more issue in the pip wheel package this morning, so we
created a new candidate build after fixing that issue.
The latest candidate builds and source code is available at
https://developer.pgadmin.org/builds/2024-07-29-1/

On Fri, Jul 26, 2024 at 5:14 PM Akshay Joshi <[email-masked]>
wrote:

>>>> We have fixed the Ubuntu 24 crash issue. The latest candidate builds
>>>> and source code is available at

---

From: Usman Khan <[email-masked]>
Date: Mon, 29 Jul 2024 10:53:00 +0500

Hi,
I will verify on windows 11 and ubuntu 24.04. I will update till evening +5
GMT.

On Mon, Jul 29, 2024 at 10:18 AM Akshay Joshi <[email-masked]>
wrote:

> On Fri, Jul 26, 2024 at 5:14 PM Akshay Joshi <

---

From: Yogesh Mahajan <[email-masked]>
Date: Mon, 29 Jul 2024 15:49:51 +0530

Hi Usman,

Can you please update about installer testing?

Thanks,
Yogesh Mahajan
EnterpriseDB

On Mon, Jul 29, 2024 at 11:23 AM Usman Khan <[email-masked]> wrote:

> Hi,
> I will verify on windows 11 and ubuntu 24.04. I will update till evening
> +5 GMT.
>
> On Mon, Jul 29, 2024 at 10:18 AM Akshay Joshi <
>>>> I have verified the issue on ubuntu 24.04 and it's fixed. Users are
>>>> able to launch pgadmin 4 in desktop mode.
>>>>
>>>>>>> Yes, we'll need a respin. I'm adding code to post installation of
>>>>>>> the pgAdmin deb package to place the profile.
>>>>>>>
>>>>>>>>>> I'll have to try that locally. The other solution what most
>>>>>>>>>> people have followed is -
>>>>>>>>>>>>>>>> pgAdmin Hacker | Sr. Software Architect |
>>>>>>>>>>>>>>>> *enterprisedb.com* <https://www.enterprisedb.com/>

---

From: Usman Khan <[email-masked]>
Date: Mon, 29 Jul 2024 15:29:16 +0500

Hi,
I was aiming to finish it at the end of the day. Are we still planning to
release it today in spite of today's fix?

On Mon, Jul 29, 2024 at 3:20 PM Yogesh Mahajan <
[email-masked]> wrote:

>>>>>>>>>>>>>>> Sorry, my bad. I misread the screenshot with amd as arm.
>>>>>>>>>>>>>>> Will check once at my end.
>>>>>>>>>>>>>>>

---

From: Yogesh Mahajan <[email-masked]>
Date: Mon, 29 Jul 2024 16:08:51 +0530

Yes. We are planning to release ASAP today.

Thanks,
Yogesh Mahajan
EnterpriseDB

On Mon, Jul 29, 2024 at 3:59 PM Usman Khan <[email-masked]> wrote:

>>>>>>>> We have fixed the Ubuntu 24 crash issue. The latest
>>>>>>>> candidate builds and source code is available at

---

From: Usman Khan <[email-masked]>
Date: Mon, 29 Jul 2024 15:41:14 +0500

Okay, let me take it on priority and update here in an hour or so.

On Mon, Jul 29, 2024 at 3:39 PM Yogesh Mahajan <
[email-masked]> wrote:

>>>> I will verify on windows 11 and ubuntu 24.04. I will update till
>>>> evening +5 GMT.
>>>>
>>>>>>> I have re verified the builds on ubuntu 24.04 and windows 11 with
>>>>>>> the latest installer. Basic sanity is done for the following
>>>>>>>
>>>>>>>>>>>>>>>>>>>> I am not able to launch desktop pgadmin on ubuntu
>>>>>>>>>>>>>>>>>>>> 24.04. Getting following error
>>>>>>>>>>>>>>>>>>>>

---

From: Usman Khan <[email-masked]>
Date: Mon, 29 Jul 2024 16:32:43 +0500

Hi,
The verification is done for the following
1. ubuntu 24.04
2. windows 11

Both fresh installation and upgrade scenarios(from pgadmin 4 8.9 to 8.10)
are verified.

On Mon, Jul 29, 2024 at 3:41 PM Usman Khan <[email-masked]> wrote:

>>> I was aiming to finish it at the end of the day. Are we still planning
>>> to release it today in spite of today's fix?
>>>
>>>>>>>>>>> Yes, we'll need a respin. I'm adding code to post installation
>>>>>>>>>>> of the pgAdmin deb package to place the profile.
>>>>>>>>>>>
>>>>>>>>>>>>> I added this as mentioned in the solution and restart
>>>>>>>>>>>>> apparmor. pgAdmin started working. Now I need to figure out how I can
>>>>>>>>>>>>> create this file when installing pgAdmin.
>>>>>>>>>>>>>

---

From: Yogesh Mahajan <[email-masked]>
Date: Mon, 29 Jul 2024 17:33:27 +0530

Hi Akshay,

One round of installer testing is completed. pgAdmin4 8.10 can be released.

Thanks,
Yogesh Mahajan
EnterpriseDB

On Mon, Jul 29, 2024 at 5:03 PM Usman Khan <[email-masked]> wrote:

>>>>>>>>> I have verified the issue on ubuntu 24.04 and it's fixed. Users
>>>>>>>>> are able to launch pgadmin 4 in desktop mode.
>>>>>>>>>
>>>>>>>>>>>>>>>>>>>>>>>> *Note:-  We have transitioned from NW.js to
>>>>>>>>>>>>>>>>>>>>>>>> Electron starting with this release.*
>>>>>>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>>>>>>> Akshay Joshi
>>>>>>>>>>>>>>>>>>>>>>>>