Subject: More idiomatic python3 + fix some tests

From: Cyril Jouve <[email-masked]>
Date: Fri, 28 Aug 2020 22:57:40 +0200

Hello,

patch 1 to 6 generated mostly using 2to3:
0001: https://docs.python.org/3.8/library/2to3.html#2to3fixer-asserts
0002: https://docs.python.org/3.8/library/2to3.html#2to3fixer-filter
0003: https://docs.python.org/3.8/library/2to3.html#2to3fixer-idioms
0004: https://docs.python.org/3.8/library/2to3.html#2to3fixer-metaclass
0005: https://docs.python.org/3.8/library/2to3.html#2to3fixer-xrange
0006: https://docs.python.org/3.8/library/2to3.html#2to3fixer-unicode

patch 7 fixes change_password tests:
Less that min length : min is 8 instead of 6
Valid password : use an user different than admin user / mock mail module

patch 8 fixes ConstraintDeleteMultipleTestCase on py3.10 (using simplejson
like in all other modules).

Regards,
Cyril

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 31 Aug 2020 16:48:17 +0530

Hi Cyril

Thanks, patch applied. Please make sure to run "yarn run pep8" before
sending the patch.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Cyril Jouve <[email-masked]>
Date: Tue, 1 Sep 2020 11:06:42 +0200

thanks :)

and sure, I'll run the linter next time!

have you thought of automatic code formatters instead like yapf or black?

Le lun. 31 août 2020 à 13:18, Akshay Joshi <[email-masked]>
a écrit :

>> patch 8 fixes ConstraintDeleteMultipleTestCase on py3.10 (using
>> simplejson like in all other modules).
>>
>> Regards,
>> Cyril
>>
>
>
> --
> *Thanks & Regards*
> *Akshay Joshi*

---

From: Murtuza Zabuawala <[email-masked]>
Date: Tue, 1 Sep 2020 14:54:18 +0530

Hi,

> have you thought of automatic code formatters instead like yapf or black?

AFAIK, yapf is not consistent with formatting & black is non-configurable.
I tried both sometime back and not found useful at that time but we can
give it a shot with the new release.

-- Murtuza