Subject: [pgAdmin][RM7238] ERD: Remove foreign references when table node is removed

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 17 Mar 2022 15:22:40 +0530

Hi Hackers,

Attached patch fixes issue where foreign key is not removed even if the
referred table is removed in ERD. I have also added a check to not allow
duplicate table names.

Please review.

-- 
Thanks,
Aditya Toshniwal
pgAdmin Hacker | Software Architect | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 17 Mar 2022 17:03:28 +0530

Thanks, the patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*