Subject: pgAdmin 4 commit: Use a 'play' icon for the Execute Query button in the

From: Dave Page <[email-masked]>
Date: Tue, 03 Dec 2019 01:44:58 +0000

Use a 'play' icon for the Execute Query button in the Query Tool for greater consistency with other applications. Fixes #4711

Branch
------
master

Details
-------
https://git.postgresql.org/gitweb?p=pgadmin4.git;a=commitdiff;h=ac2bd5e6ee7c41d5fc2f4ee0036042ac79ff9320

Modified Files
--------------
docs/en_US/release_notes_4_16.rst                        | 1 +
web/pgadmin/tools/datagrid/templates/datagrid/index.html | 2 +-
2 files changed, 2 insertions(+), 1 deletion(-)

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 3 Dec 2019 15:38:01 +0530

Hi Hackers,

Attached is the patch to change toolbar icon for opening query tool inline
with execute button change.
Icon for table filter button on the toolbar is also changed as below:

On Tue, Dec 3, 2019 at 7:15 AM Dave Page <[email-masked]> wrote:

> Use a 'play' icon for the Execute Query button in the Query Tool for
> greater consistency with other applications. Fixes #4711
>
> Branch
> ------
> master
>
> Details
> -------
>

-- 
Thanks and Regards,
Aditya Toshniwal
Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Dave Page <[email-masked]>
Date: Tue, 3 Dec 2019 05:39:40 -0500

I intentionally didn't change that one as I wasn't sure what icon would be
better. I'm far from convinced that it should also be a play icon.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 3 Dec 2019 16:13:04 +0530

Hi Dave,

I've sent a patch for the new icon. It is not a play icon but thoughts on
the sent patch ? Below is the icon:

On Tue, Dec 3, 2019 at 4:09 PM Dave Page <[email-masked]> wrote:

>> Attached is the patch to change toolbar icon for opening query tool
>> inline with execute button change.

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 4 Dec 2019 11:57:59 +0530

Hi Dave,

Should I commit this patch, are you happy with the new icons?

On Tue, Dec 3, 2019 at 4:13 PM Aditya Toshniwal <
[email-masked]> wrote:

>> I intentionally didn't change that one as I wasn't sure what icon would
>> be better. I'm far from convinced that it should also be a play icon.
>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 5 Dec 2019 09:54:17 +0530

Dave,

Any update on this? Should I commit the patch?

---

From: Dave Page <[email-masked]>
Date: Thu, 5 Dec 2019 08:16:50 -0500

Yes, go ahead.

On Wed, Dec 4, 2019 at 11:24 PM Akshay Joshi <[email-masked]>
wrote:

>>> I've sent a patch for the new icon. It is not a play icon but thoughts
>>> on the sent patch ? Below is the icon:
>>>

-- 
Dave Page
VP & Chief Architect, Database Infrastructure
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 6 Dec 2019 19:28:31 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*