Subject: pgAdmin 4 commit: Hardcoded 'itsdangerous' version to <=1.1.0, as the l

From: Akshay Joshi <[email-masked]>
Date: Tue, 18 May 2021 08:13:11 +0000

Hardcoded 'itsdangerous' version to <=1.1.0, as the latest version not working correctly for pgAdmin.

Branch
------
master

Details
-------
https://git.postgresql.org/gitweb?p=pgadmin4.git;a=commitdiff;h=0a95550fc0d0f0c33df8cfab4ebf970fbfa291a4

Modified Files
--------------
requirements.txt | 1 +
1 file changed, 1 insertion(+)

---

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 31 May 2021 15:08:11 +0530

Hello,

'itsdangerous' is an important module in order to keep the sessions safe &
secure, Is there any specific reason for holding back on the older version?
IMO we need to fix what is not working instead of using the older version.

--
Regards,
Murtuza Zabuawala
*EDB*
*POWER TO POSTGRES*
https://www.edbpostgres.com

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 31 May 2021 15:13:58 +0530

Hi Murtuza

It is failing to run migrations, which is the first step to run pgAdmin 4.
Check https://redmine.postgresql.org/issues/6452

On Mon, May 31, 2021 at 3:08 PM Murtuza Zabuawala <
[email-masked]> wrote:

> On Tue, May 18, 2021 at 1:43 PM Akshay Joshi <
> [email-masked]> wrote:
>

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Dave Page <[email-masked]>
Date: Fri, 4 Jun 2021 09:35:11 +0100

Hi Akshay,

> Check https://redmine.postgresql.org/issues/6452

Is someone working on fixing that?

>> 'itsdangerous' is an important module in order to keep the sessions safe
>> & secure, Is there any specific reason for holding back on the older
>> version?

-- 
Dave Page
Blog: https://pgsnake.blogspot.com
Twitter: @pgsnake

EDB: https://www.enterprisedb.com