Subject: [pgAdmin][RM4469] Add RE-SQL test cases for Sequences

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 15 Jul 2019 16:36:15 +0530

Hi Hackers,

Attached is the patch to add RE-SQL test cases for sequences. When running
the test cases, I also found an issue (#4470
<https://redmine.postgresql.org/issues/4470>). The fix for it is included
in the patch.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Dave Page <[email-masked]>
Date: Mon, 15 Jul 2019 14:56:40 +0100

Thanks, committed.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 28 Aug 2019 18:08:44 +0530

Hi Hackers,

Attached is the patch containing further changes to sequences RE-SQL test
cases. Changes include MSQL test cases, ACL test cases and allow run
sequences test cases on EPAS servers.

Kindly review.

On Mon, Jul 15, 2019 at 7:26 PM Dave Page <[email-masked]> wrote:

>> Attached is the patch to add RE-SQL test cases for sequences. When
>> running the test cases, I also found an issue (#4470
>> <https://redmine.postgresql.org/issues/4470>). The fix for it is
>> included in the patch.
>>
>> Kindly review.
>>
>> --
>> Thanks and Regards,
>> Aditya Toshniwal

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 29 Aug 2019 11:28:16 +0530

Hi Hackers,

Kindly hold on with the patch. I think I have missed few things. :P
Will send an updated patch.

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 29 Aug 2019 12:28:46 +0530

Hi Hackers,

Attached is the updated patch.
The patch also includes some RE-SQL log additions and a change in resql
code where msql was failing if scenario data had dict data types. Code is
changed to convert dict to string before forming the URL.

Kindly review.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 29 Aug 2019 14:16:09 +0530

Thanks patch applied.

On Thu, Aug 29, 2019 at 12:29 PM Aditya Toshniwal <
[email-masked]> wrote:

>>> Attached is the patch containing further changes to sequences RE-SQL
>>> test cases. Changes include MSQL test cases, ACL test cases and allow run

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*