Subject: pgAdmin 4 - Modify babel config for gettext

From: "Libor M." <[email-masked]>
Date: Sat, 12 Sep 2020 10:56:12 +0200

Hi,
now not all occurrences of gettext are generated to messages.pot file.
In attachment is babel config modification for improve.

Best regards,

Libor M.

E-mail: [email-masked]
GitHub: https://github.com/liborm85
diff --git a/web/babel.cfg b/web/babel.cfg
index 1e185bed8..71fc49993 100644
--- a/web/babel.cfg
+++ b/web/babel.cfg
@@ -3,7 +3,7 @@
 [jinja2: **/templates/**.sql]
 [ignore: **/vendor/**.js]
 [javascript: **/static/**.js]
-[javascript: **/templates/about/**.js]
-[javascript: **/templates/dashboard/**.js]
+[javascript: **/static/**.jsx]
+[javascript: **/templates/**/js/**.js]
 [jinja2: **/templates/**.js]
 extensions=jinja2.ext.autoescape,jinja2.ext.with_
\ No newline at end of file

---

From: Akshay Joshi <[email-masked]>
Date: Sun, 13 Sep 2020 19:05:51 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*