Subject: SonarQube Fixes #4 Database & Foreign Tables

From: Rahul Shirsat <[email-masked]>
Date: Thu, 21 Jan 2021 14:35:35 +0530

Hi Hackers,

Please find the attached patch which resolves the sonar qube issues
relating:

   1. *Foreign Tables* -*Refactor this function to reduce its Cognitive
   Complexity from 67 to the 15 allowed.*
   2. *Database* -*Refactor this function to reduce its Cognitive
   Complexity from 17 to the 15 allowed.*

-- 
*Rahul Shirsat*
Senior Software Engineer | EnterpriseDB Corporation.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 21 Jan 2021 14:47:15 +0530

Hi Rahul

Following are the review comments:

   - Change the name of the function 'get_pg_db_properties'. The function
   returns lastsysoid and datistemplate only and I assume it is applicable for
   PG/EPAS both.
   - Add comments for all the new functions introduce in the patch.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Rahul Shirsat <[email-masked]>
Date: Thu, 21 Jan 2021 17:24:01 +0530

On Thu, Jan 21, 2021 at 2:47 PM Akshay Joshi <[email-masked]>
wrote:

>  *Done!*

>  *Added!*

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 29 Jan 2021 11:58:59 +0530

Thanks, patch applied.

On Thu, Jan 21, 2021 at 5:25 PM Rahul Shirsat <
[email-masked]> wrote:

>
>
> On Thu, Jan 21, 2021 at 2:47 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Rahul
>>
>>    - Change the name of the function 'get_pg_db_properties'. The
>>    function returns lastsysoid and datistemplate only and I assume it is
>>    applicable for PG/EPAS both.
>>
>>  *Done!*
>
>>