Subject: [pgAdmin] RM6117 Unable to update column level privileges from security tab.

From: Rahul Shirsat <[email-masked]>
Date: Sat, 6 Feb 2021 01:24:39 +0530

Hi Hackers,

Please find the attached patch which resolves the issue of unable to update
column level privileges in the security tab.

Additionally, when the user tries to change grantee, the sql wasn't
generating, this too issue is resolved.

This security privilege issue is resolved for the following nodes:

1.) Tables (test cases are skipped as there are no resql test cases based
on pg & ppas)
2.) Columns
3.) Views
4.) MViews
5.) Types
6.) Functions
7.) Procedures
8.) Trigger functions
9.) Sequences
10.) Schema

P.S for committer : Warning of whitespaces after applying patch should be
ignored as it is a part of resql test case results.

-- 
*Rahul Shirsat*
Senior Software Engineer | EnterpriseDB Corporation.

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 8 Feb 2021 09:53:05 +0530

Hi Rahul,

On Sat, Feb 6, 2021 at 1:25 AM Rahul Shirsat <[email-masked]>
wrote:

> Hi Hackers,
>
> Please find the attached patch which resolves the issue of unable to
> update column level privileges in the security tab.
>
Probably change the SQL generation logic to avoid the trailing whitespaces ?

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Rahul Shirsat <[email-masked]>
Date: Mon, 8 Feb 2021 15:28:02 +0530

Akshay,

Removed some whitespace warnings. While this new patch is applied there are
still 2 unknown whitespace warnings which are pointing to the wrong
location.

Could you please let me know if this works?

On Mon, Feb 8, 2021 at 9:53 AM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Rahul,
>
> On Sat, Feb 6, 2021 at 1:25 AM Rahul Shirsat <
> [email-masked]> wrote:
>
>> Hi Hackers,
>>

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 9 Feb 2021 16:45:28 +0530

Hi Nikhil

Can you please review the patch thoroughly?

On Mon, Feb 8, 2021 at 3:28 PM Rahul Shirsat <[email-masked]>
wrote:

> Akshay,
>
> Removed some whitespace warnings. While this new patch is applied there
> are still 2 unknown whitespace warnings which are pointing to the wrong
> location.
>
>>> 1.) Tables (test cases are skipped as there are no resql test cases
>>> based on pg & ppas)
>>> 2.) Columns
>>> 3.) Views
>>> 4.) MViews
>>> 5.) Types
>>> 6.) Functions
>>> 7.) Procedures
>>> 8.) Trigger functions
>>> 9.) Sequences
>>> 10.) Schema
>>>
>>> P.S for committer : Warning of whitespaces after applying patch should
>>> be ignored as it is a part of resql test case results.
>>>

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Nikhil Mohite <[email-masked]>
Date: Wed, 10 Feb 2021 12:57:05 +0530

Hi Rahul,

While reviewing the patch, found one observation with update privileges.
1. While creating a table add any privileges for any user and save. (e.g:
Add Insert to user1)
2. Open table properties and update privileges for the same user by editing
the privilege (e.g: Now Add Update to user1), check "Save" button is
enabled.(Don't save the new privileges )
3. Now if we retore the privilege to older values "Save" button remains
enabled. (e.g:  Deselect "Update" from privilege.)
4. SQL is also getting generated after restoring the privilege to older
values.

Regards,
Nikhil Mohite.

On Tue, Feb 9, 2021 at 4:45 PM Akshay Joshi <[email-masked]>
wrote:

> On Mon, Feb 8, 2021 at 3:28 PM Rahul Shirsat <

---

From: Rahul Shirsat <[email-masked]>
Date: Wed, 10 Feb 2021 15:12:59 +0530

Hi Team,

The above observation is fixed. Please find the updated patch below.

On Wed, Feb 10, 2021 at 12:57 PM Nikhil Mohite <
[email-masked]> wrote:

> 2. Open table properties and update privileges for the same user by
> editing the privilege (e.g: Now Add Update to user1), check "Save" button
> is enabled.(Don't save the new privileges )

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 10 Feb 2021 17:56:57 +0530

Thanks, patch applied.

On Wed, Feb 10, 2021 at 3:13 PM Rahul Shirsat <
[email-masked]> wrote:

>> On Tue, Feb 9, 2021 at 4:45 PM Akshay Joshi <
>> [email-masked]> wrote:
>>
>>> Hi Nikhil
>>>
>>>>>> P.S for committer : Warning of whitespaces after applying patch
>>>>>> should be ignored as it is a part of resql test case results.
>>>>>>